summaryrefslogtreecommitdiff
path: root/www-servers/tornado/tornado-6.0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/tornado/tornado-6.0.4.ebuild')
-rw-r--r--www-servers/tornado/tornado-6.0.4.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/www-servers/tornado/tornado-6.0.4.ebuild b/www-servers/tornado/tornado-6.0.4.ebuild
deleted file mode 100644
index 4e12f2e4081b..000000000000
--- a/www-servers/tornado/tornado-6.0.4.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Python web framework and asynchronous networking library"
-HOMEPAGE="https://www.tornadoweb.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-CDEPEND="
- >=dev-python/pycurl-7.19.3.1[${PYTHON_USEDEP}]
- >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
-"
-DEPEND="
- test? (
- ${CDEPEND}
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="${CDEPEND}"
-
-distutils_enable_sphinx docs \
- dev-python/sphinx_rtd_theme \
- dev-python/sphinxcontrib-asyncio
-
-src_prepare() {
- # it used to pass, so apparently something changed somewhere
- sed -i -e 's:test_method_after_redirect:_&:' \
- tornado/test/httpclient_test.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local -x ASYNC_TEST_TIMEOUT=60
- cd "${BUILD_DIR}/lib" || die
- "${PYTHON}" -m tornado.test.runtests --verbose ||
- die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- if use examples; then
- docinto examples
- dodoc -r demos/.
- docompress -x /usr/share/doc/${PF}/examples
- fi
- distutils-r1_python_install_all
-}