summaryrefslogtreecommitdiff
path: root/www-servers
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/Manifest.gzbin4539 -> 4541 bytes
-rw-r--r--www-servers/civetweb/Manifest2
-rw-r--r--www-servers/civetweb/civetweb-1.16.ebuild34
3 files changed, 36 insertions, 0 deletions
diff --git a/www-servers/Manifest.gz b/www-servers/Manifest.gz
index 55463ad645c8..972264924657 100644
--- a/www-servers/Manifest.gz
+++ b/www-servers/Manifest.gz
Binary files differ
diff --git a/www-servers/civetweb/Manifest b/www-servers/civetweb/Manifest
index f46f06ed0880..e135290059a0 100644
--- a/www-servers/civetweb/Manifest
+++ b/www-servers/civetweb/Manifest
@@ -1,3 +1,5 @@
DIST civetweb-1.12.tar.gz 11463079 BLAKE2B 1182f798a2f9cdb34754b3c0edf80160efda31f72d800b26b27ec36ff4a5623745495a52632a128aefda67c6b902250c4e01ec7debd73d4a95abfc42a1b17ea6 SHA512 d6f8d29011bc1accd5384856bef16c0f20305f622a8f8c127cdf3ae5c567db3aba0d76293cc8c77f90f4989c44b2896a45e533d2f2408cc49488d1d234d308f5
+DIST civetweb-1.16.tar.gz 12094780 BLAKE2B 7c2e094f6e4730459082c8557925f51775beb0b07fa01291f7a46bf3ea69d7f879566e71a8c6d5b9ad1b3b28d910d99e587eccc703e8b2d3d5797f589c24074a SHA512 a0b943dfc76d7fd47f5a7d2c834fd38ddd4cf01a11730cf2f7cfaf32fea9698f59672f3a0f86ac80e0abc315d94d2367a500d37013f305c87d45e84cf39ca816
EBUILD civetweb-1.12.ebuild 769 BLAKE2B 9c2afeec53c6da6a2bc3cdb7232136509a97ad01f887ea260ae698d9ed1f909bb71afe56518e5a32a25170fc094c5c03c37052e822a670cd604f176225c56802 SHA512 9e6190ed161755b4cab0030f590f8881237437b94fb2a91974bd20b211ebbb52cfc43562bdb823ab434f6b416fb8f66685ac7db1b353c34975ca7d39b93ff953
+EBUILD civetweb-1.16.ebuild 804 BLAKE2B f9d531f1f64b5214002ce1de0eb7916b460a7a20d1bbd2b35ef72b8429a3a08dbf31d112bfe5b8bd1d9f85c2a4654e875d0c7c67b74d73398ddf0d5f0d375e8e SHA512 d5061e66553ee5c426f47df15fff8a896066f4c152c19ae13dc5d8e5164feb50db370e51f5c6a25c9f401f654569cf5f316e1cf5abb8babd11998142fbd39078
MISC metadata.xml 405 BLAKE2B ea4ece3b3fc9977f4a2affefd24093a3c0c08557902e26c5482aef43857073caa76812c4e4ae43fb3291a2f7136cde7630e4a1031252dd9aef07f8c3ef615147 SHA512 4b4d9571ecb4b737508051ec5ed050723eb50b326ce413cd8b53f7183146710b22b978641ed390168488bc533dee34cb5e90cc7919f8434eeebcb41fbe92ebef
diff --git a/www-servers/civetweb/civetweb-1.16.ebuild b/www-servers/civetweb/civetweb-1.16.ebuild
new file mode 100644
index 000000000000..83bd33185971
--- /dev/null
+++ b/www-servers/civetweb/civetweb-1.16.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+HOMEPAGE="https://github.com/civetweb/civetweb/"
+DESCRIPTION="Embedded C/C++ web server"
+SRC_URI="https://github.com/civetweb/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="cxx +server ssl"
+
+DEPEND="ssl? ( dev-libs/openssl:0= )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=OFF
+ -DBUILD_SHARED_LIBS=ON
+ -DCIVETWEB_BUILD_TESTING=OFF
+ -DCIVETWEB_ENABLE_LUA=OFF
+ -DCIVETWEB_ENABLE_DUKTAPE=OFF
+ -DCIVETWEB_ENABLE_WEBSOCKETS=ON
+ -DCIVETWEB_ENABLE_CXX="$(usex cxx)"
+ -DCIVETWEB_ENABLE_SERVER_EXECUTABLE="$(usex server)"
+ -DCIVETWEB_ENABLE_SSL="$(usex ssl)"
+ )
+
+ cmake_src_configure
+}