summaryrefslogtreecommitdiff
path: root/x11-apps/xinit
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps/xinit')
-rw-r--r--x11-apps/xinit/Manifest2
-rw-r--r--x11-apps/xinit/xinit-1.4.1.ebuild21
2 files changed, 12 insertions, 11 deletions
diff --git a/x11-apps/xinit/Manifest b/x11-apps/xinit/Manifest
index 22733d69edd4..902fbcc285a6 100644
--- a/x11-apps/xinit/Manifest
+++ b/x11-apps/xinit/Manifest
@@ -8,5 +8,5 @@ AUX xinit-1.4.0-startx-current-vt.patch 740 BLAKE2B f5ac87b96f76bd4c845cde4844f9
AUX xinit-1.4.1-move-serverauthfile-into-tmp.patch 745 BLAKE2B 6a964926b4f5eda566be4ff5c0f015ca2d3a9f39f16ba5af0cf3816c56cf458e616645ace1b8be9873c604322ab56b118a7a9e531533f8617cb647a57cf0cf3e SHA512 0fb93f0cebfd4091d7e58139ef375fec931392159b3b060d699d118c89d4403fd5cee82cd35582aedf7dd752aee495724119f864b17988d0dd9a5dfe76c88ce0
AUX xserverrc.2 143 BLAKE2B b33fac4b5ba731c79167d21a07840c46abfbb33e8fbb80aa1c3f23a8717f836819da3a947b72bd99c7a14516534e9771033bcd1e26d167f2f7083be20eae3b2f SHA512 61afea54f66b9f397860e467cf87a41e1d9f97d7194930bccc254e44dd4178bca7b402bff7aa2a1d6f44a91680f3f1ee10a5b57e527aaff80438623edc1b07c5
DIST xinit-1.4.1.tar.bz2 176206 BLAKE2B 1c20f34db344eb967ac230a0cd61ad07d0089668aea32973e9b8b9749e5260ad5d93a7f6642a4f2c8d6b01870696e4e1e422790c2954320039aa85e6dba8870a SHA512 6cbc5d025a891c419f3f4493381b2fca57a67d78df866d2f16a83426f86bad6eca7f240fac12b25cbcc63df0fec41f625407184e044898602d66483715315340
-EBUILD xinit-1.4.1.ebuild 2232 BLAKE2B 622e9f5e36c269abb54801a9b17457b711a5f3ff6383a0ac5f52e33c5fc5d0de2f0454e3d21d4443ba4ef4bbd050e7ab5c5a3948063fe8f4ec5e7848038655aa SHA512 a835583d0846e90cd1f3eb34c4f61369079fac6ecd39833338aedcc6e99c5227498e6fd72dbc5ff9a410fe96eb02c21f617c45cc9b5b2fdc20059f1de549b553
+EBUILD xinit-1.4.1.ebuild 2239 BLAKE2B 8cd8ec8946f8e7f8e3bdad7b031e23776407e3ea0e36d07a6daecdaf748d15396d8e80b03295516e60cd825d329c66cf2902a51e69bbe44bf343c28ecb429e43 SHA512 1184baf128170a5c9256abc8efda02c683ab65542bd81f8ac07d3511b02ab7cc672cb4dd0f14022cbfb1dfe33852fb27d8fff393441874441abbedfc8b9d3e55
MISC metadata.xml 477 BLAKE2B 96cb48063d5da3ee74d3c6080b849841fb1b276338db584d51bac71b5b2c3df0ecd876055a3c11e18f46c4d879a90ef91713166cae2aef65ea7725ab639b116f SHA512 c3e1095f0e3e017439777b3113d16ceccdc5ee7127da7f9e994126d6f51227a07c831e082d58c9c094aa6fed3e789458a212e27ec497fd3a14ba4cc5e4956205
diff --git a/x11-apps/xinit/xinit-1.4.1.ebuild b/x11-apps/xinit/xinit-1.4.1.ebuild
index 70f4ab1c68ae..ae32ff253c54 100644
--- a/x11-apps/xinit/xinit-1.4.1.ebuild
+++ b/x11-apps/xinit/xinit-1.4.1.ebuild
@@ -8,11 +8,10 @@ inherit xorg-3
DESCRIPTION="X Window System initializer"
LICENSE="${LICENSE} GPL-2"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~arm-linux ~x86-linux"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~arm-linux ~x86-linux"
IUSE="twm"
RDEPEND="
- !<x11-base/xorg-server-1.8.0
x11-apps/xauth
x11-libs/libX11
"
@@ -53,7 +52,7 @@ src_install() {
}
pkg_postinst() {
- if ! has_version 'x11-apps/xinit'; then
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
ewarn "If you use startx to start X instead of a login manager like gdm/kdm,"
ewarn "you can set the XSESSION variable to anything in /etc/X11/Sessions/ or"
ewarn "any executable. When you run startx, it will run this as the login session."
@@ -64,11 +63,13 @@ pkg_postinst() {
ewarn " env-update && source /etc/profile"
fi
- if has_version "<${CATEGORY}/${PN}-1.4.1"; then
- ewarn "Starting with ${CATEGORY}/${PN}-1.4.1 serverauth files are no longer kept in the"
- ewarn "home directory but rather are created in \$TMPDIR (typically /tmp). The change"
- ewarn "is transparent for most of users, however those that use runtime temporary"
- ewarn "directories cleaning tools, like app-admin/tmpreaper, may need to adjust them"
- ewarn "not to remove the 'serverauth.*' files."
- fi
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test "$v" "-lt" "1.4.1"; then
+ ewarn "Starting with ${CATEGORY}/${PN}-1.4.1 serverauth files are no longer kept in the"
+ ewarn "home directory but rather are created in \$TMPDIR (typically /tmp). The change"
+ ewarn "is transparent for most of users, however those that use runtime temporary"
+ ewarn "directories cleaning tools, like app-admin/tmpreaper, may need to adjust them"
+ ewarn "not to remove the 'serverauth.*' files."
+ fi
+ done
}