summaryrefslogtreecommitdiff
path: root/x11-apps/xisxwayland
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps/xisxwayland')
-rw-r--r--x11-apps/xisxwayland/Manifest4
-rw-r--r--x11-apps/xisxwayland/xisxwayland-2.ebuild25
-rw-r--r--x11-apps/xisxwayland/xisxwayland-9999.ebuild27
3 files changed, 23 insertions, 33 deletions
diff --git a/x11-apps/xisxwayland/Manifest b/x11-apps/xisxwayland/Manifest
index 2ec51ea82868..cbcc0f77773a 100644
--- a/x11-apps/xisxwayland/Manifest
+++ b/x11-apps/xisxwayland/Manifest
@@ -1,4 +1,4 @@
DIST xisxwayland-2.tar.xz 5220 BLAKE2B 47bd626ad2cbeb5b0e114a4f603858c82f4f870f16de038bcadd3010f90e140fb8a3b0531e4102da7527c49bcc6bae6039aa6b42c6182da80467d5a3f040b817 SHA512 b89e19c85a5cd7e62a52e22772f80f03bfea069e31412ca11ac38174c4a2994be559e9d5fb49e6d1921b3f1b06ee71b50ede48990a1e7804a96207b08fc7827f
-EBUILD xisxwayland-2.ebuild 661 BLAKE2B 1990f4d4c829ffb120c0e9569aeba483b7219f995510435e937916d239c0d8f1ce0cf36269aeb435c86827c1bd018672f9c5363ac3222be30d0999388857aff5 SHA512 cad417e156f38b595593ca102e77e5908d96e3b7434e14aa0de6d7e9055f6acd878ee89ed8b3204ebacf46aab52a34fef0b0c6f082771a0810e5ff93b890b924
-EBUILD xisxwayland-9999.ebuild 662 BLAKE2B 635fcfe4558cb05792fc914001592ea832245db9e5d1edb540160ca07cdd6a31b282f04b92d42e0bb633112cdfccccecb78424ddd20fc1af21443a064a84abcd SHA512 59b4d65e59ac2476d165837473c1f467c94ac4ea30e142f788ec071c83240832a806e065b479d7a3ca79f0f1fd25a17988fd6f9695e36a478192a534f2385a7e
+EBUILD xisxwayland-2.ebuild 442 BLAKE2B 02e80e999a3ca0fbecf59a4cb2a4aec7e173291c20ecd26698ddfc42d28ddb58123b92e7b2157f5f6941b82ac5720285508808e399bfecd0f98825a2bb9d1e19 SHA512 1899aa7630a972d68b65bb78ffa72214805b584634cf7fc808d8f30bc9fd17e47ac133ac41dfcffe8fc3b77b73a612ceab3a29e6b9df04a182ededc440e00e97
+EBUILD xisxwayland-9999.ebuild 442 BLAKE2B 02e80e999a3ca0fbecf59a4cb2a4aec7e173291c20ecd26698ddfc42d28ddb58123b92e7b2157f5f6941b82ac5720285508808e399bfecd0f98825a2bb9d1e19 SHA512 1899aa7630a972d68b65bb78ffa72214805b584634cf7fc808d8f30bc9fd17e47ac133ac41dfcffe8fc3b77b73a612ceab3a29e6b9df04a182ededc440e00e97
MISC metadata.xml 342 BLAKE2B 22542ce434659a09b234891625d25ab44fb54fb27fc81950a9682ae3250c9b2826c6387460111227f8295ebfe5207a8f7ccb60b80ad79e96c47bfe5ae132170f SHA512 401c20493181e036e7117caa4562c0cf8075b17e1ee384b5e5d6d22a301d6e901fd0936a2cd1f52b50b79e2932f80ceb1a9fd47fc6ede220ce37c9bb2d50aeec
diff --git a/x11-apps/xisxwayland/xisxwayland-2.ebuild b/x11-apps/xisxwayland/xisxwayland-2.ebuild
index c82f6bbc37cd..ea94facec6af 100644
--- a/x11-apps/xisxwayland/xisxwayland-2.ebuild
+++ b/x11-apps/xisxwayland/xisxwayland-2.ebuild
@@ -1,29 +1,24 @@
-# Copyright 2020-2022 Gentoo Authors
+# Copyright 2020-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+XORG_TARBALL_SUFFIX="xz"
-if [[ ${PV} = 9999* ]]; then
- GIT_ECLASS="git-r3"
- EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/app/${PN}.git"
-fi
-
-inherit ${GIT_ECLASS} meson
+inherit xorg-3 meson
-DESCRIPTION="Tool to determine whether the X server in use is Xwayland"
-HOMEPAGE="https://gitlab.freedesktop.org/xorg/app/xisxwayland"
-if [[ ${PV} = 9999* ]]; then
- SRC_URI=""
-else
+if [[ ${PV} != *9999* ]]; then
KEYWORDS="amd64 ~loong"
- SRC_URI="https://xorg.freedesktop.org/archive/individual/app/${P}.tar.xz"
fi
-LICENSE="MIT"
-SLOT="0"
+DESCRIPTION="Tool to determine whether the X server in use is Xwayland"
RDEPEND="
x11-libs/libX11
x11-libs/libXrandr"
DEPEND="${RDEPEND}
x11-base/xorg-proto"
+
+# Override xorg-3's src_prepare
+src_prepare() {
+ default
+}
diff --git a/x11-apps/xisxwayland/xisxwayland-9999.ebuild b/x11-apps/xisxwayland/xisxwayland-9999.ebuild
index c7f9d5034c09..ea94facec6af 100644
--- a/x11-apps/xisxwayland/xisxwayland-9999.ebuild
+++ b/x11-apps/xisxwayland/xisxwayland-9999.ebuild
@@ -1,29 +1,24 @@
-# Copyright 2020-2022 Gentoo Authors
+# Copyright 2020-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+XORG_TARBALL_SUFFIX="xz"
-if [[ ${PV} = 9999* ]]; then
- GIT_ECLASS="git-r3"
- EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/app/${PN}.git"
-fi
-
-inherit ${GIT_ECLASS} meson
+inherit xorg-3 meson
-DESCRIPTION="Tool to determine whether the X server in use is Xwayland"
-HOMEPAGE="https://gitlab.freedesktop.org/xorg/app/xisxwayland"
-if [[ ${PV} = 9999* ]]; then
- SRC_URI=""
-else
- KEYWORDS="~amd64 ~loong"
- SRC_URI="https://xorg.freedesktop.org/archive/individual/app/${P}.tar.xz"
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="amd64 ~loong"
fi
-LICENSE="MIT"
-SLOT="0"
+DESCRIPTION="Tool to determine whether the X server in use is Xwayland"
RDEPEND="
x11-libs/libX11
x11-libs/libXrandr"
DEPEND="${RDEPEND}
x11-base/xorg-proto"
+
+# Override xorg-3's src_prepare
+src_prepare() {
+ default
+}