summaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.10.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/xf86-input-evdev/xf86-input-evdev-2.10.6.ebuild')
-rw-r--r--x11-drivers/xf86-input-evdev/xf86-input-evdev-2.10.6.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.10.6.ebuild b/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.10.6.ebuild
new file mode 100644
index 000000000000..bd887a55784c
--- /dev/null
+++ b/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.10.6.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit linux-info xorg-2
+
+DESCRIPTION="Generic Linux input driver"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86"
+IUSE=""
+
+RDEPEND=">=x11-base/xorg-server-1.18[udev]
+ dev-libs/libevdev
+ sys-libs/mtdev
+ virtual/libudev:="
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6
+ x11-base/xorg-proto"
+
+pkg_pretend() {
+ if use kernel_linux ; then
+ CONFIG_CHECK="~INPUT_EVDEV"
+ fi
+ check_extra_config
+}