summaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-input-libinput
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/xf86-input-libinput')
-rw-r--r--x11-drivers/xf86-input-libinput/Manifest2
-rw-r--r--x11-drivers/xf86-input-libinput/xf86-input-libinput-1.5.0.ebuild22
2 files changed, 24 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-libinput/Manifest b/x11-drivers/xf86-input-libinput/Manifest
index e0a109585b3d..8226208b26bc 100644
--- a/x11-drivers/xf86-input-libinput/Manifest
+++ b/x11-drivers/xf86-input-libinput/Manifest
@@ -1,3 +1,5 @@
DIST xf86-input-libinput-1.4.0.tar.xz 326708 BLAKE2B 258c0c1584e3dd370044be9702d669b1036597d936af9b7bda6cbd19642a9188054beab85a18d5571020859b3046db916efe05d4691f468eae706bd78c33e2d6 SHA512 b286b5425aeda5cfecd1de7f59663d169b95ffc55474dfbf28c2e13e5221cbeecd472d40b6094c0a937f83db67bf58a7fe0e07d25b6a6945d3fd669e717fc0bf
+DIST xf86-input-libinput-1.5.0.tar.xz 330088 BLAKE2B 33c81de8bd621c6c838420747f140689c8937d7fae4c4a5beef7ede65a1ad24e1bb620f2798a002de063eef47a6e6a5a3e8bad405370b02f87aa63c2f7897afb SHA512 03090beb7c162fdf55e9bb9da41ffb8601b20047e4a53895bad27de47b3197fc920e710f26fa23e7322b367ab65fa56ba5f9a195ec69801529af3958632c2d6e
EBUILD xf86-input-libinput-1.4.0.ebuild 486 BLAKE2B 92a331c5721edc8effa88d39082ac301a56e3571c3b9b903ce02be4b4ea4078fb4e3dd72433be0f5e33e09554e8e797241284557194b67c60ae9cba55106dfd7 SHA512 8eeafbb899fb326dd18e8a030bf88d11058c97a861c9d0453f42d01cc830c0b13ac568f0528331231e9051cd254942a9827e9d11b8247e050f0d72ff9b5d1353
+EBUILD xf86-input-libinput-1.5.0.ebuild 493 BLAKE2B 397665f778be041313f121fbaec0821b3eac605e9b73c5f3072396b2330f37b3ac2162e77b90563bffef10e24919441add174a096c415ce2df50ebdbccbc23a4 SHA512 a31d1651f850440f5eac9e0982a5bd1f2da605f3b87e834409322d7f3ac961b96438fa2c678701415bb0d945ea6ca96ae1c68ad1aa4cad747e48da89b1cfb1dc
MISC metadata.xml 353 BLAKE2B 9790292864502624cc387d0287d377bb6a071503c58a9f7125bd710de7899376aa571950794990eac13569c5d4af6d9023419496cffd1b2b3324f5f35447bea7 SHA512 772506e8c790596eef1dfca9bf35f9eec5df4aae388bcec0390fbb9f8c96b7b3a95d286c3379e71628d0b0b3847a33635facef3528b2978ef0b8dd4b93e84f2e
diff --git a/x11-drivers/xf86-input-libinput/xf86-input-libinput-1.5.0.ebuild b/x11-drivers/xf86-input-libinput/xf86-input-libinput-1.5.0.ebuild
new file mode 100644
index 000000000000..ecaa02a6523d
--- /dev/null
+++ b/x11-drivers/xf86-input-libinput/xf86-input-libinput-1.5.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+XORG_TARBALL_SUFFIX="xz"
+
+inherit linux-info xorg-3
+
+DESCRIPTION="X.org input driver based on libinput"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND=">=dev-libs/libinput-1.23.0:0="
+DEPEND="${RDEPEND}
+ >=x11-base/xorg-proto-2021.5"
+
+DOCS=( "README.md" )
+
+pkg_pretend() {
+ CONFIG_CHECK="~TIMERFD"
+ check_extra_config
+}