summaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild')
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild48
1 files changed, 35 insertions, 13 deletions
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild
index 3f5390aec7a0..4ab1064d9902 100644
--- a/x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild
@@ -1,28 +1,40 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-XORG_DRI=always
-inherit linux-info xorg-2
+inherit linux-info
+
+DESCRIPTION="ATI video driver"
+HOMEPAGE="https://www.x.org/wiki/ati/"
if [[ ${PV} == 9999* ]]; then
- SRC_URI=""
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/xorg/driver/${PN}"
+ inherit autotools git-r3
+ LIVE_DEPEND=">=x11-misc/util-macros-1.18"
else
+ SRC_URI="mirror://xorg/driver/${P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
fi
-DESCRIPTION="ATI video driver"
-HOMEPAGE="https://www.x.org/wiki/ati/"
-
+LICENSE="MIT"
+SLOT="0"
IUSE="+glamor udev"
-RDEPEND=">=x11-libs/libdrm-2.4.78[video_cards_radeon]
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ >=x11-libs/libdrm-2.4.78[video_cards_radeon]
>=x11-libs/libpciaccess-0.8.0
glamor? ( x11-base/xorg-server[glamor] )
- udev? ( virtual/libudev:= )"
-DEPEND="${RDEPEND}
- x11-base/xorg-proto"
+ udev? ( virtual/libudev:= )
+"
+DEPEND="
+ ${LIVE_DEPEND}
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
pkg_pretend() {
if use kernel_linux ; then
@@ -35,10 +47,20 @@ pkg_pretend() {
check_extra_config
}
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
src_configure() {
- XORG_CONFIGURE_OPTIONS=(
+ local econfargs=(
$(use_enable glamor)
$(use_enable udev)
)
- xorg-2_src_configure
+ econf "${econfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
}