summaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.5.ebuild')
-rw-r--r--x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.5.ebuild b/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.5.ebuild
new file mode 100644
index 000000000000..5dab6f4b5ef8
--- /dev/null
+++ b/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1 xorg-2
+
+DESCRIPTION="QEMU QXL paravirt video driver"
+
+KEYWORDS="amd64 x86"
+IUSE="xspice"
+REQUIRED_USE="xspice? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ xspice? (
+ app-emulation/spice
+ ${PYTHON_DEPS}
+ )
+ x11-base/xorg-server[-minimal]
+ >=x11-libs/libdrm-2.4.46"
+DEPEND="${RDEPEND}
+ x11-proto/xf86dgaproto
+ >=app-emulation/spice-protocol-0.12.0"
+
+src_prepare() {
+ python_fix_shebang scripts
+ xorg-2_src_prepare
+}
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable xspice)
+ )
+ xorg-2_src_configure
+}