summaryrefslogtreecommitdiff
path: root/x11-libs/libICE
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/libICE')
-rw-r--r--x11-libs/libICE/Manifest2
-rw-r--r--x11-libs/libICE/libICE-1.0.10.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/x11-libs/libICE/Manifest b/x11-libs/libICE/Manifest
index f870c5c06c8a..0b4cb3381616 100644
--- a/x11-libs/libICE/Manifest
+++ b/x11-libs/libICE/Manifest
@@ -1,3 +1,5 @@
+DIST libICE-1.0.10.tar.bz2 393116 BLAKE2B 2089cbddab679f8565f0b7bf0313616b71f33cd403aea2cb84032a247c1e1d01de343058c31be73214bd6dea7fc167fa6a0f81704c960bc279d904bdf4bf804f SHA512 2f1ef2c32c833c71894a08fa7e7ed53f301f6c7bd22485d71c12884d8e8b36b99f362ec886349dcc84d08edc81c8b2cea035320831d64974edeba021b433c468
DIST libICE-1.0.9.tar.bz2 384921 BLAKE2B 701122d9ef6bfa9077f63b35131dc4603964dbb0b7f58bd54ca49e25be24265142d39da4e1f7c72fdf4945dfb358f7b061acb848dfb0c1bcac5973c9fc728a26 SHA512 daa8126ee5279c08f801274a2754132762dea2a40f4733c4b0bf8e8bdad61cba826939a2e067beb3524e256a98a2b83f23c8d4643f3e75a284ab02cc73da41b7
+EBUILD libICE-1.0.10.ebuild 687 BLAKE2B 4918627ae3f1d155a386be4a9f3997de07c0dabdebaa6a0ed21cdf6f35638c6d526aec89a4592946e94fa663b9ba4bec9b459cc0c902b118789239d9720d1124 SHA512 655ae8e0a943dda1bedf3ddba8d78d91de6b503470808002980d26c821e804cf14dc193dc38d2d3040064407397789f06c1e534eca7afac3a4b40c273af74b42
EBUILD libICE-1.0.9-r2.ebuild 749 BLAKE2B 38eb1e857197de5a71012b4f683f70e5d65f6266f5043abb8f012314450a66bcddd99a67e8f3aeae4032d5d3536de29ad6c08f9c273313894420eafeba0972d7 SHA512 7d108ed97b6e210227ca741d517589a828ad52a6d46b09e955416ed07629918574885aa11c45db9017b1fcba420ab62e243cf23b9ba2fd547cf92c8a2bd949b1
MISC metadata.xml 230 BLAKE2B 70bf59e64305ef14908197f2aa7ffbc1769ade265097da68e001245451658af5921760c91cb74aae717543ea0017e2471fd94bfc5c4c447d2d60e2c23aa3b007 SHA512 d7a2643abd1904cc5ff4d91cbb6f1baeb7f75fd1db542c5e14f19412f4f0bd4b903f8e703a7662ba7482c79dac5529057760b6427599d35e0842755fd946e057
diff --git a/x11-libs/libICE/libICE-1.0.10.ebuild b/x11-libs/libICE/libICE-1.0.10.ebuild
new file mode 100644
index 000000000000..fcf1112fea93
--- /dev/null
+++ b/x11-libs/libICE/libICE-1.0.10.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_MULTILIB=yes
+inherit xorg-3
+
+DESCRIPTION="X.Org Inter-Client Exchange library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="ipv6"
+
+DEPEND="x11-base/xorg-proto
+ x11-libs/xtrans"
+RDEPEND="${DEPEND}
+ elibc_glibc? ( dev-libs/libbsd )"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable ipv6)
+ --disable-docs
+ --disable-specs
+ --without-fop
+ )
+}