summaryrefslogtreecommitdiff
path: root/x11-libs/xcb-util/xcb-util-0.4.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/xcb-util/xcb-util-0.4.0-r2.ebuild')
-rw-r--r--x11-libs/xcb-util/xcb-util-0.4.0-r2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/x11-libs/xcb-util/xcb-util-0.4.0-r2.ebuild b/x11-libs/xcb-util/xcb-util-0.4.0-r2.ebuild
new file mode 100644
index 000000000000..8a42590c5db8
--- /dev/null
+++ b/x11-libs/xcb-util/xcb-util-0.4.0-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_MULTILIB=yes
+inherit xorg-3
+
+DESCRIPTION="X C-language Bindings sample implementations"
+HOMEPAGE="https://xcb.freedesktop.org/ https://gitlab.freedesktop.org/xorg/lib/libxcb-util"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+
+RDEPEND=">=x11-libs/libxcb-1.9.1:=[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+PDEPEND="
+ >=x11-libs/xcb-util-cursor-0.1.1:=[${MULTILIB_USEDEP}]
+ >=x11-libs/xcb-util-image-${PV}:=[${MULTILIB_USEDEP}]
+ >=x11-libs/xcb-util-keysyms-${PV}:=[${MULTILIB_USEDEP}]
+ >=x11-libs/xcb-util-renderutil-0.3.9:=[${MULTILIB_USEDEP}]
+ >=x11-libs/xcb-util-wm-${PV}:=[${MULTILIB_USEDEP}]
+"