summaryrefslogtreecommitdiff
path: root/x11-libs/xtrans/xtrans-1.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/xtrans/xtrans-1.5.0.ebuild')
-rw-r--r--x11-libs/xtrans/xtrans-1.5.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/x11-libs/xtrans/xtrans-1.5.0.ebuild b/x11-libs/xtrans/xtrans-1.5.0.ebuild
new file mode 100644
index 000000000000..05aaabe65c58
--- /dev/null
+++ b/x11-libs/xtrans/xtrans-1.5.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_PACKAGE_NAME="lib${PN}"
+# this package just installs some .c and .h files, no libraries
+XORG_DOC=doc
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X.Org xtrans library"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_enable doc docs)
+ $(use_with doc xmlto)
+ --without-fop
+ )
+ xorg-3_src_configure
+}