summaryrefslogtreecommitdiff
path: root/x11-misc/autorandr
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/autorandr')
-rw-r--r--x11-misc/autorandr/Manifest3
-rw-r--r--x11-misc/autorandr/autorandr-1.12.1-r1.ebuild65
-rw-r--r--x11-misc/autorandr/autorandr-9999.ebuild4
3 files changed, 69 insertions, 3 deletions
diff --git a/x11-misc/autorandr/Manifest b/x11-misc/autorandr/Manifest
index 82422064085d..3f44fc9dcee4 100644
--- a/x11-misc/autorandr/Manifest
+++ b/x11-misc/autorandr/Manifest
@@ -1,4 +1,5 @@
DIST autorandr-1.12.1.tar.gz 45550 BLAKE2B 5b434325d13c00c3fa70b5d09edb540cdcf3bb921307c60f2c616231e7a87ea85f60e39500ed8116f28619139f71ecc4a8fa153ffadc6b8d74df570736a0d815 SHA512 a7e095eb96e7e0d3a5b3b2122d68a3d3a5121d8be7a86ddd9f837ad42b7a53ed5ee45151f23861c5b900e214a4dfc0c575f45fe70c8c5587562a4035458137a0
+EBUILD autorandr-1.12.1-r1.ebuild 1334 BLAKE2B 989f72dd2b1a728bf59c0d6cfc273efe81e1b4fd4bb53136f500d087b5f6d035fbe5f5d714b426cfa7aecba1c18e2e3bf49dabb213a8bdc22ef14e3858fb9338 SHA512 cb4b2dcdd702612e04822fd9eafff8863f4563dbf965c83a3c393f5793020a53e63031627e6dc889ca49712c07d901d8da88840edf548d4d3b580bd5bcd66936
EBUILD autorandr-1.12.1.ebuild 1316 BLAKE2B 5c13c316e1a1878f7507178c15dea312af45867841bc70baa26f0ea5aab8f9e98a99e9953a85aacff68a075abacf914c9e8009726cc4890a733086ada9c2a74f SHA512 5b6f8d86a28c19763d690abfc65787e3a1b7fac32be2a5689e29fd2ef92928865771e12163f242e25be9297eaaba238d7fa6d13420ca645933a9ed0eb7905a83
-EBUILD autorandr-9999.ebuild 1318 BLAKE2B 5892e8c61fe2ff231f20937d9bd31004eb2710043fc48a077214b07d7f68716409b7049113ecbd6a444f6b694d40265179f87312fc2e7e60afd90aa7753c02a2 SHA512 d4339f7ee1675fb0a539cbae61126c7f4fcb40014abacf08db1d58b37992a2250709fe041f6a620758bfb0abee6ea95b95321dc2de96840ff8546080051a586e
+EBUILD autorandr-9999.ebuild 1334 BLAKE2B 989f72dd2b1a728bf59c0d6cfc273efe81e1b4fd4bb53136f500d087b5f6d035fbe5f5d714b426cfa7aecba1c18e2e3bf49dabb213a8bdc22ef14e3858fb9338 SHA512 cb4b2dcdd702612e04822fd9eafff8863f4563dbf965c83a3c393f5793020a53e63031627e6dc889ca49712c07d901d8da88840edf548d4d3b580bd5bcd66936
MISC metadata.xml 355 BLAKE2B 51f7f0670462cbded6b65379488447fca9862fd75ecc262e3a627c268d184abae82feb8a3835486d2c39d18ad0882db6f1f6c9ff9df4fac19457b4ec3a1f6621 SHA512 a9e16f58beeda5d64b48240ef23dfe4349d8c962e08df19cd3fa60846891719fceba2f69b3affba64b8d6f8c2ec96b1dc544a4ada52efd53e6d15b1aa1734677
diff --git a/x11-misc/autorandr/autorandr-1.12.1-r1.ebuild b/x11-misc/autorandr/autorandr-1.12.1-r1.ebuild
new file mode 100644
index 000000000000..0badb8f708aa
--- /dev/null
+++ b/x11-misc/autorandr/autorandr-1.12.1-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit bash-completion-r1 distutils-r1 systemd udev
+
+if [[ "${PV}" = "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/phillipberndt/${PN}.git"
+else
+ SRC_URI="https://github.com/phillipberndt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Automatically select a display configuration based on connected devices"
+HOMEPAGE="https://github.com/phillipberndt/autorandr"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="launcher systemd udev"
+
+RDEPEND="
+ x11-apps/xrandr
+ launcher? ( x11-libs/libxcb )
+ udev? ( virtual/udev )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_compile() {
+ distutils-r1_src_compile
+
+ if use launcher; then
+ emake contrib/autorandr_launcher/autorandr-launcher
+ fi
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ doman autorandr.1
+
+ local targets=(
+ autostart_config
+ bash_completion
+ $(usev launcher)
+ $(usev systemd)
+ $(usev udev)
+ )
+
+ emake DESTDIR="${D}" \
+ BASH_COMPLETIONS_DIR="$(get_bashcompdir)" \
+ SYSTEMD_UNIT_DIR="$(systemd_get_systemunitdir)" \
+ UDEV_RULES_DIR="$(get_udevdir)"/rules.d \
+ $(printf "install_%s " "${targets[@]}")
+}
+
+pkg_postinst() {
+ if use udev; then
+ udev_reload
+ fi
+}
diff --git a/x11-misc/autorandr/autorandr-9999.ebuild b/x11-misc/autorandr/autorandr-9999.ebuild
index 4433c9b58d70..0badb8f708aa 100644
--- a/x11-misc/autorandr/autorandr-9999.ebuild
+++ b/x11-misc/autorandr/autorandr-9999.ebuild
@@ -20,7 +20,7 @@ HOMEPAGE="https://github.com/phillipberndt/autorandr"
LICENSE="GPL-3"
SLOT="0"
-IUSE="launcher udev"
+IUSE="launcher systemd udev"
RDEPEND="
x11-apps/xrandr
@@ -46,8 +46,8 @@ src_install() {
local targets=(
autostart_config
bash_completion
- systemd
$(usev launcher)
+ $(usev systemd)
$(usev udev)
)