summaryrefslogtreecommitdiff
path: root/x11-misc/devilspie2
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/devilspie2')
-rw-r--r--x11-misc/devilspie2/Manifest2
-rw-r--r--x11-misc/devilspie2/devilspie2-0.45.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/x11-misc/devilspie2/Manifest b/x11-misc/devilspie2/Manifest
index 21a40dff36ad..02fc27815558 100644
--- a/x11-misc/devilspie2/Manifest
+++ b/x11-misc/devilspie2/Manifest
@@ -1,3 +1,5 @@
DIST devilspie2-0.44.tar.xz 46028 BLAKE2B e9ec3115781575c331d91e982fd1c71361ea57004a1b7ff234957998d3d44fd4e9a0ca1fde9d133e9e4c2d01b6e8d192921554eae8b83acfb0e3fa44b0c9fd23 SHA512 f01f2d044a670dd9b1b97e896a3e8ebcac3e67daea9f08a14bce26fe8084b85f7fdaa0ed147aba91626200f882eddeba7e0ec18f0f565cb7557ffb2ac74a4a64
+DIST devilspie2_0.45-src.tar.gz 59202 BLAKE2B 8b8fc5c9a91f0e8c2ff8494c52f6c6e406babb86ed8985573b2509ed4d4741d81dff8bab6267508d727a2d73abd031d4d4d74e7ac1a05948e331b8712b1b390c SHA512 4dc9e8c81cf2b20e828509483243d23fbd296955050d3d4c4693754b62762d44022f4969a077bd7d75e6b0e0c89168c31c09b1dc345bf3275b444b9b6c9e0515
EBUILD devilspie2-0.44.ebuild 1013 BLAKE2B f143a76fa037d65369c451bca3589c24640ed08562ea61837fde4f9ced87a5c237bfdd8641485c625c1333fef353860e523c1d28b9174d45819d31d4b09f73f6 SHA512 6db38664e5a44e5a4340e929c6de052f7d3cd5bb0be83ef4ea4d9290baba8e67ea5d586e9a175854f0e71142435a0c2a470f46434faddb3e836a68ad85f4b523
+EBUILD devilspie2-0.45.ebuild 999 BLAKE2B 62d5ef2bf549392f39556a79263cb8f7956741d8d431c08c76ef61dab10617f26269d639f837832eefc7caaa38ce7a7eb24be01122020ff9cad75e873bed3f55 SHA512 68d9953a58e75ec178ec6e91869ddbcffe53155a7e1478578ea1e70dcd5cd16e21855cbaf9fc7c96f0c62557fcdc569c4cadf302a5a4a2a5cdc336a235a348ff
MISC metadata.xml 327 BLAKE2B deb8a111c8827befa1e4637d81d1605f10de1dfedbf2693a47361a5de9a01392934957906a48419acd421704db1c01029411a0f71d42c26525d5294e66a73e35 SHA512 d876e887ddd0c79605cedbad6aa23026c12a3a44a690fc5fcf84ae804fd22dffff76c1487d1a529af52db3594899f79d986aadf6fd44593a90d53db21d1c3f61
diff --git a/x11-misc/devilspie2/devilspie2-0.45.ebuild b/x11-misc/devilspie2/devilspie2-0.45.ebuild
new file mode 100644
index 000000000000..d8a404af85ca
--- /dev/null
+++ b/x11-misc/devilspie2/devilspie2-0.45.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+inherit lua-single plocale toolchain-funcs
+
+DESCRIPTION="Window matching utility with Lua scripting"
+HOMEPAGE="https://www.nongnu.org/devilspie2/"
+SRC_URI="mirror://nongnu/${PN}/${P/-/_}-src.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="
+ ${LUA_DEPS}
+ dev-libs/glib:2
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libwnck:3
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_compile() {
+ tc-export CC PKG_CONFIG
+
+ local PLOCALES="fi fr it ja nl pt_BR ru sv"
+
+ DEVILSPIE2_ARGS=(
+ PREFIX="${EPREFIX}"/usr
+ LANGUAGES="$(plocale_get_locales)"
+ LUA="${ELUA}"
+ )
+
+ emake "${DEVILSPIE2_ARGS[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" "${DEVILSPIE2_ARGS[@]}" install
+ einstalldocs
+
+ dodoc -r doc/examples
+}