summaryrefslogtreecommitdiff
path: root/x11-misc/flow-pomodoro/flow-pomodoro-1.2.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/flow-pomodoro/flow-pomodoro-1.2.0-r1.ebuild')
-rw-r--r--x11-misc/flow-pomodoro/flow-pomodoro-1.2.0-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-misc/flow-pomodoro/flow-pomodoro-1.2.0-r1.ebuild b/x11-misc/flow-pomodoro/flow-pomodoro-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..4285248dec78
--- /dev/null
+++ b/x11-misc/flow-pomodoro/flow-pomodoro-1.2.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="A pomodoro app that blocks distractions while you work"
+HOMEPAGE="https://github.com/iamsergio/flow-pomodoro"
+SRC_URI="https://github.com/iamsergio/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtquickcontrols:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-qt-5.12.patch" )