summaryrefslogtreecommitdiff
path: root/x11-misc/grabc/grabc-1.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/grabc/grabc-1.1-r2.ebuild')
-rw-r--r--x11-misc/grabc/grabc-1.1-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-misc/grabc/grabc-1.1-r2.ebuild b/x11-misc/grabc/grabc-1.1-r2.ebuild
new file mode 100644
index 000000000000..fc963dc09905
--- /dev/null
+++ b/x11-misc/grabc/grabc-1.1-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="Identify color of a pixel on the screen by clicking on a pixel on the screen"
+HOMEPAGE="https://www.muquit.com/muquit/software/grabc/grabc.html"
+SRC_URI="https://www.muquit.com/muquit/software/${PN}/${PN}${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S="${WORKDIR}/${PN}${PV}"
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ dobin grabc
+ einstalldocs
+}