summaryrefslogtreecommitdiff
path: root/x11-misc/gtkdialog/gtkdialog-99999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/gtkdialog/gtkdialog-99999.ebuild')
-rw-r--r--x11-misc/gtkdialog/gtkdialog-99999.ebuild25
1 files changed, 18 insertions, 7 deletions
diff --git a/x11-misc/gtkdialog/gtkdialog-99999.ebuild b/x11-misc/gtkdialog/gtkdialog-99999.ebuild
index d90e208f2ef6..131519d09a46 100644
--- a/x11-misc/gtkdialog/gtkdialog-99999.ebuild
+++ b/x11-misc/gtkdialog/gtkdialog-99999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit autotools git-r3
+EAPI=7
+inherit autotools git-r3 xdg-utils
DESCRIPTION="A small utility for fast and easy GUI building"
HOMEPAGE="https://github.com/oshazard/gtkdialog"
@@ -11,14 +11,14 @@ EGIT_REPO_URI="https://github.com/oshazard/gtkdialog"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="gtk3"
+IUSE="gtk2"
RDEPEND="
- !gtk3? (
+ gtk2? (
x11-libs/gtk+:2
x11-libs/vte:0=
)
- gtk3? (
+ !gtk2? (
x11-libs/gtk+:3
x11-libs/vte:2.91=
)
@@ -30,6 +30,9 @@ DEPEND="
virtual/pkgconfig
virtual/yacc
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.3-fno-common.patch
+)
src_prepare() {
default
@@ -38,7 +41,7 @@ src_prepare() {
src_configure() {
econf \
- $(use_enable gtk3)
+ $(usex gtk2 --disable-gtk3 --enable-gtk3)
}
src_compile() {
@@ -51,3 +54,11 @@ src_install() {
emake DESTDIR="${D}" UPDATE_ICON_CACHE=true install
einstalldocs
}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}