summaryrefslogtreecommitdiff
path: root/x11-misc/kbdd/kbdd-0.7.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/kbdd/kbdd-0.7.1.ebuild')
-rw-r--r--x11-misc/kbdd/kbdd-0.7.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-misc/kbdd/kbdd-0.7.1.ebuild b/x11-misc/kbdd/kbdd-0.7.1.ebuild
new file mode 100644
index 000000000000..32b3f011cfb1
--- /dev/null
+++ b/x11-misc/kbdd/kbdd-0.7.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools eutils vcs-snapshot
+
+DESCRIPTION="Very simple layout switcher"
+HOMEPAGE="https://github.com/qnikst/kbdd"
+SRC_URI="https://github.com/qnikst/kbdd/tarball/v${PV} -> ${PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus"
+
+DEPEND="dev-libs/glib:2=
+ x11-libs/libX11:0=
+ dbus? (
+ sys-apps/dbus:0=
+ >=dev-libs/dbus-glib-0.86:0=
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable dbus)
+}