summaryrefslogtreecommitdiff
path: root/x11-misc/libinput-gestures
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/libinput-gestures')
-rw-r--r--x11-misc/libinput-gestures/Manifest3
-rw-r--r--x11-misc/libinput-gestures/files/libinput-gestures-2.73-python-39-tests.patch13
-rw-r--r--x11-misc/libinput-gestures/libinput-gestures-2.73.ebuild69
3 files changed, 85 insertions, 0 deletions
diff --git a/x11-misc/libinput-gestures/Manifest b/x11-misc/libinput-gestures/Manifest
index f99a599f3a26..f9ed620836e8 100644
--- a/x11-misc/libinput-gestures/Manifest
+++ b/x11-misc/libinput-gestures/Manifest
@@ -1,4 +1,7 @@
+AUX libinput-gestures-2.73-python-39-tests.patch 369 BLAKE2B c3157b64059679bf1e6f8e7ff24aef39032272f42d8f45d521c60c112afa33ed600fd05ee9dc6c06c7cc1c0c038ebd2991973df67c06bd7a88ea1cc7d269777c SHA512 ef0b9a72bcc298ca3a15d122a29ea8229efe338741a41d5bbd1d84680b893edf60a5605b9e777952be29198ce44629619cdbc9cf37fc8a41f9763a098f6679c9
DIST libinput-gestures-2.56.tar.gz 26293 BLAKE2B b48a33c13efc63545bcb5ae722066493bd6aba083a07b1ebbf10eea69afa2a8f9d80a92b60dda3e8472a55851b70e84cf7c10e0bf3428c2278dd3ef5b6f65d0d SHA512 f215444dbe7e70ae137404beb25d5a60c5a618fb2d3d20eb9b4cf3f94cbc93a7e42a5fa82efdea082e2fa229c95d86c02df91c59f4a51c067e47ccf5dcf79fa7
+DIST libinput-gestures-2.73.tar.gz 28771 BLAKE2B 9f3c546b637b0038431517e2df5e3dfba4fbb7db708f108dd7a979e6674b2bdd44b2b877b5e200c05373a57bfeffefadfde59bc6c403f7188e349c2e051d8683 SHA512 8e46931c76541eb836b1bd79295f05fdc0e22091d1693eac1cc9c16407830806f9e56819e5fb8ba3eed7a26664946010d24d62d99131bcf71b1d8a3682f34ec6
EBUILD libinput-gestures-2.56.ebuild 1274 BLAKE2B bf578943d51a96ab2acaa5fb1090e985345e51d4218c7d96718c5f589d785d5d94149f598f59f48f5065dad3a0650d5c41773d137eb3cbd0cab93596ad709ef1 SHA512 9b2d1c6fe8441430ce1cbcb7a22d22e74d0b3fee24162a18a844c3cdb751a2b18d5f13e25832d36d95268406cc0253f6d4433ec396921318885b800e2fef72a8
+EBUILD libinput-gestures-2.73.ebuild 1478 BLAKE2B f8a56533e6b8d4699f00b6ecf61f59587e81ace7545a10d2ee679754abe4b849efd6cae9ac5db0d2e3f9b0e8018273f006bca1e28f685007f19704992112a6ca SHA512 750fb0f3eca2c27966b6227e51875cd84afa2684e17ead551b2d8ca82a4c0601870e66c4baea838a9eb6904ad6a86880d00d4dc3d7d7dafb4678584ca73296b7
EBUILD libinput-gestures-9999.ebuild 1274 BLAKE2B bf578943d51a96ab2acaa5fb1090e985345e51d4218c7d96718c5f589d785d5d94149f598f59f48f5065dad3a0650d5c41773d137eb3cbd0cab93596ad709ef1 SHA512 9b2d1c6fe8441430ce1cbcb7a22d22e74d0b3fee24162a18a844c3cdb751a2b18d5f13e25832d36d95268406cc0253f6d4433ec396921318885b800e2fef72a8
MISC metadata.xml 856 BLAKE2B 92642eca2e06d1564b21c0ceebf435180829cdbc23937c815e55cb5cc71ca8514c5862704f04744a865dba3741102fa58b855487c441fb1e73b2d82ef023c197 SHA512 0038eb454c3f8f263acb75ea2b2840abc0cbb7174496b0832acbdc210b3182c14e0088b6eb3f5591e95b32ab837c6c98111c21494bb6d074418a9d493afc5875
diff --git a/x11-misc/libinput-gestures/files/libinput-gestures-2.73-python-39-tests.patch b/x11-misc/libinput-gestures/files/libinput-gestures-2.73-python-39-tests.patch
new file mode 100644
index 000000000000..4d14f13f2b8d
--- /dev/null
+++ b/x11-misc/libinput-gestures/files/libinput-gestures-2.73-python-39-tests.patch
@@ -0,0 +1,13 @@
+diff --git a/internal b/internal
+index 432179d..6898173 100755
+--- a/internal
++++ b/internal
+@@ -1,7 +1,7 @@
+ #!/usr/bin/env python3
+ 'Command line program to exercise/test/debug the _internal command.'
+ # Mark Blakeney, Oct 2019
+-import sys, importlib, argparse
++import sys, importlib.util, importlib.machinery, argparse
+ from pathlib import Path
+
+ CMD = '_internal'
diff --git a/x11-misc/libinput-gestures/libinput-gestures-2.73.ebuild b/x11-misc/libinput-gestures/libinput-gestures-2.73.ebuild
new file mode 100644
index 000000000000..0335db2c4cf6
--- /dev/null
+++ b/x11-misc/libinput-gestures/libinput-gestures-2.73.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit python-single-r1 xdg
+
+DESCRIPTION="Actions gestures on your touchpad using libinput"
+HOMEPAGE="https://github.com/bulletmark/libinput-gestures"
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/bulletmark/${PN}.git"
+else
+ SRC_URI="https://github.com/bulletmark/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+# This is completely broken
+RESTRICT="test"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/libinput
+ x11-misc/wmctrl
+ x11-misc/xdotool
+"
+DEPEND="
+ dev-libs/libinput
+ dev-util/desktop-file-utils
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-python-39-tests.patch"
+)
+
+src_prepare() {
+ default
+
+ # Fix docdir installation path
+ sed -i "/^DOCDIR/s@\$NAME@${PF}@" libinput-gestures-setup \
+ || die "sed failed for libinput-gestures-setup"
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ default
+ # Actually respect the python target setting
+ python_doscript "${PN}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+
+ elog "You must be in the input group to read the touchpad device."
+
+ if ! has_version x11-libs/gtk+:3 ; then
+ elog "${PN}-setup script supports GNOME via x11-libs/gtk+:3."
+ fi
+ if ! has_version kde-plasma/kde-cli-tools:5 ; then
+ elog "${PN}-setup script supports Plasma 5 via kde-plasma/kde-cli-tools:5."
+ fi
+}