summaryrefslogtreecommitdiff
path: root/x11-misc/mate-notification-daemon
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/mate-notification-daemon')
-rw-r--r--x11-misc/mate-notification-daemon/Manifest2
-rw-r--r--x11-misc/mate-notification-daemon/mate-notification-daemon-1.22.0.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/x11-misc/mate-notification-daemon/Manifest b/x11-misc/mate-notification-daemon/Manifest
index 903c516e95ff..f96620bc7ed8 100644
--- a/x11-misc/mate-notification-daemon/Manifest
+++ b/x11-misc/mate-notification-daemon/Manifest
@@ -1,4 +1,6 @@
AUX org.freedesktop.Notifications.service 94 BLAKE2B 1a97aac2db9c803c9e4babf9067283b564a1eecb1d251aee3a5e66b8a4f63d2554e3e09ea06749383ce3d5b8e77c8cc3bd87ae2dde48ae8feb4886ecaf7a3c27 SHA512 0575cbfc094455c0a2f04faa534a5e0d9cc41e6d9566ab9bcb0fcbce99e142213ded786ad00c36dc434ae1b9208d34d234a341dfc86adb72925dad0ee2b25f97
DIST mate-notification-daemon-1.18.1.tar.xz 330940 BLAKE2B e05d2b69a66037a49cf0a1aa44a417d9fb55fecc1dd713861907b38d0361d6a9d79faa95094027add0d0e549a979eb237e8e71e1e2102664813b7745f34316f3 SHA512 92edb738e38b879a94985d97c961fd900853e330cc49024cf33a1b564734e86c076b47a05c64ec7ea34a170425b97f80aedb60ad14db98718c4609c464e091e4
+DIST mate-notification-daemon-1.22.0.tar.xz 360676 BLAKE2B 0eb50a6179b5b90243e8206bbbb6c3ce1bf65cf3b2969e0c259e4bdebdf6e86d769f74020509cc170b087a02c6295007f83efc950407f803be6e717b0fc900ae SHA512 1345604dee1315843ad5a6920aab7cbe1544c8f7c7ccea686e5684c7ea5272fa09d27edbcc996f6a568f8b3760f561b84901c44f93f1b3ae2d5ddcd3c3ce86fc
EBUILD mate-notification-daemon-1.18.1.ebuild 1032 BLAKE2B 5ebe5bee75855a462c86e3490738dbc92b566700907addf857cf11fb4c259da209e425f93e2a8b58b90ced736eb2f1c861b681b52984c4a22458850637b564a0 SHA512 80c2d4d22ad21388adf2f8aece0af19d927290b2d0f4808cb0d52e35c409a1ed8b7f02da0ad6c7c0ca569a4510f47237b7cda8df3e53c2e82b5e41663daeb9fa
+EBUILD mate-notification-daemon-1.22.0.ebuild 1007 BLAKE2B 405fee97b5332ad0b90001c82d74777e822549e06e80ddae9068aeea853f13e43c149af5a9e8adecdbc694ff683e4eec6715309c5ab607100dda31eefa20bbf7 SHA512 6e3b94fcb60b6c75063a4102618e90d8a448e34b89afd126f4bb64243634f257f0e0da553166661cbee2c7ec7bc28eddd53dd87cf4031c39d464363d6ae42507
MISC metadata.xml 353 BLAKE2B 774bcae8807bbb16a1ee8bc12320e487ec817fb45d3169f4929cbd8c3f7f33a35eb1aad2682e5d87131567c56e6ffe8f2bdbda612c58926ddc3d78b14cb69e53 SHA512 3f46b4bb5e12fdb448e7b7f54db4f4a4683cbdbd89019156601abf80be0333690b65670fb110120cf613dd42ecdfb38b329ddde67fd265257d6ddb32e24bfbbd
diff --git a/x11-misc/mate-notification-daemon/mate-notification-daemon-1.22.0.ebuild b/x11-misc/mate-notification-daemon/mate-notification-daemon-1.22.0.ebuild
new file mode 100644
index 000000000000..f9f44a9d3f4f
--- /dev/null
+++ b/x11-misc/mate-notification-daemon/mate-notification-daemon-1.22.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="MATE Notification daemon"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE=""
+
+COMMON_DEPEND="dev-libs/atk
+ >=dev-libs/dbus-glib-0.78
+ >=dev-libs/glib-2.50:2
+ >=sys-apps/dbus-1
+ x11-libs/cairo
+ >=x11-libs/gdk-pixbuf-2.22:2
+ >=x11-libs/libnotify-0.7
+ x11-libs/libX11
+ virtual/libintl
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/libwnck-3:3
+ >=media-libs/libcanberra-0.4:0[gtk3]
+ !x11-misc/notify-osd
+ !x11-misc/qtnotifydaemon
+ !x11-misc/notification-daemon"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+ app-arch/xz-utils
+ >=dev-util/intltool-0.50.1
+ sys-devel/gettext:*
+ >=sys-devel/libtool-2.2.6:2
+ virtual/pkgconfig:*"
+
+src_configure() {
+ mate_src_configure
+}
+
+src_install() {
+ mate_src_install
+
+ insinto /usr/share/dbus-1/services
+ doins "${FILESDIR}/org.freedesktop.Notifications.service"
+}