summaryrefslogtreecommitdiff
path: root/x11-misc/mixer_app/mixer_app-1.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/mixer_app/mixer_app-1.8.0.ebuild')
-rw-r--r--x11-misc/mixer_app/mixer_app-1.8.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/mixer_app/mixer_app-1.8.0.ebuild b/x11-misc/mixer_app/mixer_app-1.8.0.ebuild
new file mode 100644
index 000000000000..256f6968c369
--- /dev/null
+++ b/x11-misc/mixer_app/mixer_app-1.8.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+MY_P=Mixer.app-${PV}
+
+DESCRIPTION="mixer_app has volume controllers that can be configured to handle sound sources"
+HOMEPAGE="http://www.fukt.bsnet.se/~per/mixer/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ virtual/os-headers
+ x11-proto/xextproto"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="ChangeLog README"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_compile() {
+ tc-export CXX
+ emake
+}