summaryrefslogtreecommitdiff
path: root/x11-misc/polybar
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/polybar')
-rw-r--r--x11-misc/polybar/Manifest5
-rw-r--r--x11-misc/polybar/files/polybar-3.7.2-gcc15-cstdint-includes.patch97
-rw-r--r--x11-misc/polybar/polybar-3.7.1-r1.ebuild6
-rw-r--r--x11-misc/polybar/polybar-3.7.2.ebuild71
4 files changed, 177 insertions, 2 deletions
diff --git a/x11-misc/polybar/Manifest b/x11-misc/polybar/Manifest
index 9f8a509d0c0a..1a58b4aed77b 100644
--- a/x11-misc/polybar/Manifest
+++ b/x11-misc/polybar/Manifest
@@ -1,3 +1,6 @@
+AUX polybar-3.7.2-gcc15-cstdint-includes.patch 2184 BLAKE2B 0d906e4a01c92fc50ffd3cb887eadd1103ba0899aa6604bac0bf5d2fb0d231aadfd7bc1e5c3378accd9abccd6ace0fb15f1ace4a85155459d616de9ff64ea17d SHA512 169c9f5a602d0df718b52de4dff2b6250cf593e4acd2623dfb8e8059b45b0f483cc11a814661287362b25182268cbd6209752b74a1124cd3e3a7e23bcfd2cf27
DIST polybar-3.7.1.tar.gz 495162 BLAKE2B 33ffb3bb3595a41cb82a5ee70c79f5a31f23b6463c156a704546c803f0f006780c59b04fe2d1479f52dd15a44534687f130dfde794ac08218df2b634b34838de SHA512 cb248fd904a89dbd88d2d1ab71aeaf31e2b5781304f126aeb489da1238681e354d5347555076e814751ef5bb6717a3a6742d1726cf4721697e75694c7643bed4
-EBUILD polybar-3.7.1-r1.ebuild 1518 BLAKE2B 1a9ff335b3e7402106b805d1b55cb99bd887de3b8f73828a768a358b8958c5749278f8c99c7d3541c3ce0039b22727cec3b21711ce5baf701c92c76659fc2937 SHA512 af8743c608403dff1ced983637d8ac294f41c8b3987a938afc1f71dc0eb6dd506fd70f62f98e804623c2c36dff609596744477e81d62c3052acf164477398d54
+DIST polybar-3.7.2.tar.gz 494383 BLAKE2B dda97c42de5f32a005ae6d4de737651278df0364187c735d7fa8a6d34e644b917ba3f32859cc19bd869c43f5d14f73ca734a4227651eb267724d808e4a766e08 SHA512 a0ee701533e101789f7eb95c71717ecf1d389a10b202d19261f9f71fee9d43fb8be17fb63e4a056c5e8bd62d2e669c95ee4d4b8c6bb06b933e1e4b26ab1a0624
+EBUILD polybar-3.7.1-r1.ebuild 1631 BLAKE2B 226f1293a5d34cf421b26d55c98916a0e7d55a609d622113a6b5363c9347852bfd778440c39a2f86d54e36d59aa721d697136c3a2f72a82b4cf97879a4f5d44d SHA512 6402c85813b18d29897076e1ad88da26b9c0465081c4b7ea1f3fca0af13971af16052dfcdd86d56cde4716e7f1989625af57fc49672b212077e6dba429eb8b5b
+EBUILD polybar-3.7.2.ebuild 1695 BLAKE2B 5666aef38ff0a9fc437bbb728560d1f2c2d999075357cfae7c5d57a7806a6174b14ade7e80e089d5d95cf2de21fe33fe80cde2656995445c29685623802994e0 SHA512 7b7e248ff90dec7c6e5e4c4ff6fd59600094cc2956200315433d0f6ce2903023d5242cedfe552c1536a0154c83d55172210c4359064fa0779312e06cf6aaace5
MISC metadata.xml 585 BLAKE2B c792f265587effc07acc20f097adc1a1975d23ddf55ceb07b4bda02e61e1b48b1d20c5a07792ac18fa5f02949e0a88bc18fe6df2fffd9454406cda34ac33654b SHA512 c3f9080f68d989dbfd75492ec0c4870e4df9b0525a69256ac95bf55eea60022ac018cc1afe42677bc8f822beec75d137e1e7c8a876763c72664541a0a54b28f1
diff --git a/x11-misc/polybar/files/polybar-3.7.2-gcc15-cstdint-includes.patch b/x11-misc/polybar/files/polybar-3.7.2-gcc15-cstdint-includes.patch
new file mode 100644
index 000000000000..97d9a4c7720b
--- /dev/null
+++ b/x11-misc/polybar/files/polybar-3.7.2-gcc15-cstdint-includes.patch
@@ -0,0 +1,97 @@
+commit e79b671aa7bc4edbae5d8272d523caa092f7548d
+Author: John Helmert III <ajak@gentoo.org>
+Date: Fri Aug 30 23:13:23 2024 -0700
+
+ add missing cstdint includes
+
+ In GCC 15, cstdint is less commonly included in stdlib headers so we
+ need explicit includes: https://gcc.gnu.org/gcc-15/porting_to.html
+
+ See-Also: https://bugs.gentoo.org/937526
+ Signed-off-by: John Helmert III <ajak@gentoo.org>
+
+diff --git a/include/ipc/decoder.hpp b/include/ipc/decoder.hpp
+index 9d1afe1c..dcdf9e1a 100644
+--- a/include/ipc/decoder.hpp
++++ b/include/ipc/decoder.hpp
+@@ -5,6 +5,8 @@
+ #include "errors.hpp"
+ #include "ipc/msg.hpp"
+
++#include <cstdint>
++
+ POLYBAR_NS
+
+ namespace ipc {
+diff --git a/include/ipc/encoder.hpp b/include/ipc/encoder.hpp
+index 1fd36f60..ebb1ea82 100644
+--- a/include/ipc/encoder.hpp
++++ b/include/ipc/encoder.hpp
+@@ -4,6 +4,8 @@
+ #include "errors.hpp"
+ #include "ipc/msg.hpp"
+
++#include <cstdint>
++
+ POLYBAR_NS
+
+ namespace ipc {
+diff --git a/include/ipc/msg.hpp b/include/ipc/msg.hpp
+index 1b37022d..a423d3bb 100644
+--- a/include/ipc/msg.hpp
++++ b/include/ipc/msg.hpp
+@@ -3,6 +3,7 @@
+ #include "common.hpp"
+
+ #include <array>
++#include <cstdint>
+
+ POLYBAR_NS
+
+diff --git a/include/utils/color.hpp b/include/utils/color.hpp
+index 491d48ee..9d301af7 100644
+--- a/include/utils/color.hpp
++++ b/include/utils/color.hpp
+@@ -1,6 +1,7 @@
+ #pragma once
+
+ #include <cstdlib>
++#include <cstdint>
+
+ #include "common.hpp"
+
+diff --git a/include/utils/string.hpp b/include/utils/string.hpp
+index 45eaec06..27e06f7a 100644
+--- a/include/utils/string.hpp
++++ b/include/utils/string.hpp
+@@ -1,5 +1,6 @@
+ #pragma once
+
++#include <cstdint>
+ #include <sstream>
+
+ #include "common.hpp"
+diff --git a/src/ipc/encoder.cpp b/src/ipc/encoder.cpp
+index 87cbd915..38da55a1 100644
+--- a/src/ipc/encoder.cpp
++++ b/src/ipc/encoder.cpp
+@@ -2,6 +2,7 @@
+
+ #include <cassert>
+ #include <cstring>
++#include <cstdint>
+
+ POLYBAR_NS
+
+diff --git a/src/utils/color.cpp b/src/utils/color.cpp
+index 59fa59ae..7e47dad5 100644
+--- a/src/utils/color.cpp
++++ b/src/utils/color.cpp
+@@ -1,6 +1,7 @@
+ #include "utils/color.hpp"
+
+ #include <algorithm>
++#include <cstdint>
+
+ POLYBAR_NS
+
diff --git a/x11-misc/polybar/polybar-3.7.1-r1.ebuild b/x11-misc/polybar/polybar-3.7.1-r1.ebuild
index 68165661b062..acdb2155246d 100644
--- a/x11-misc/polybar/polybar-3.7.1-r1.ebuild
+++ b/x11-misc/polybar/polybar-3.7.1-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake python-single-r1
+inherit cmake optfeature python-single-r1
DESCRIPTION="A fast and easy-to-use tool for creating status bars"
HOMEPAGE="https://github.com/polybar/polybar"
@@ -61,3 +61,7 @@ src_configure() {
cmake_src_configure
}
+
+pkg_postinst() {
+ optfeature "Unprivileged display backlight control via udev" sys-power/acpilight
+}
diff --git a/x11-misc/polybar/polybar-3.7.2.ebuild b/x11-misc/polybar/polybar-3.7.2.ebuild
new file mode 100644
index 000000000000..7dfd36994d4a
--- /dev/null
+++ b/x11-misc/polybar/polybar-3.7.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit cmake optfeature python-single-r1
+
+DESCRIPTION="A fast and easy-to-use tool for creating status bars"
+HOMEPAGE="https://github.com/polybar/polybar"
+SRC_URI="https://github.com/polybar/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="alsa curl doc i3wm ipc mpd network pulseaudio"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep 'x11-base/xcb-proto[${PYTHON_USEDEP}]')
+ dev-libs/libuv:=
+ media-libs/fontconfig
+ media-libs/freetype
+ x11-base/xorg-proto
+ x11-libs/cairo[X,xcb(+)]
+ x11-libs/libxcb:=
+ x11-libs/xcb-util
+ x11-libs/xcb-util-cursor
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-xrm
+ alsa? ( media-libs/alsa-lib )
+ curl? ( net-misc/curl )
+ doc? ( dev-python/sphinx )
+ i3wm? (
+ dev-libs/jsoncpp:=
+ x11-wm/i3
+ )
+ mpd? ( media-libs/libmpdclient )
+ network? ( dev-libs/libnl:3 )
+ pulseaudio? ( media-libs/libpulse )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-gcc15-cstdint-includes.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_ALSA="$(usex alsa)"
+ -DENABLE_CURL="$(usex curl)"
+ -DBUILD_DOC="$(usex doc)"
+ -DENABLE_I3="$(usex i3wm)"
+ -DBUILD_POLYBAR_MSG="$(usex ipc)"
+ -DENABLE_MPD="$(usex mpd)"
+ -DENABLE_NETWORK="$(usex network)"
+ -DENABLE_PULSEAUDIO="$(usex pulseaudio)"
+ # Bug 767949
+ -DENABLE_CCACHE="OFF"
+ -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc/"
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ optfeature "Unprivileged display backlight control via udev" sys-power/acpilight
+}