summaryrefslogtreecommitdiff
path: root/x11-misc/simpleswitcher/simpleswitcher-20191008.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/simpleswitcher/simpleswitcher-20191008.ebuild')
-rw-r--r--x11-misc/simpleswitcher/simpleswitcher-20191008.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-misc/simpleswitcher/simpleswitcher-20191008.ebuild b/x11-misc/simpleswitcher/simpleswitcher-20191008.ebuild
new file mode 100644
index 000000000000..e7051abca7cf
--- /dev/null
+++ b/x11-misc/simpleswitcher/simpleswitcher-20191008.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+SSHASH="7230421aa2e3364e3b4620f1ea3760f8f810b1a5"
+DESCRIPTION="lightweight EWMH window switcher with features and looks of dmenu"
+HOMEPAGE="https://github.com/seanpringle/simpleswitcher"
+SRC_URI="https://github.com/seanpringle/simpleswitcher/archive/${SSHASH}.tar.gz -> ${P}-${SSHASH}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libXres
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+S=${WORKDIR}/${PN}-${SSHASH}
+
+src_compile() {
+ tc-export CC
+ default
+}