summaryrefslogtreecommitdiff
path: root/x11-misc/sw-notify-send/sw-notify-send-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/sw-notify-send/sw-notify-send-9999.ebuild')
-rw-r--r--x11-misc/sw-notify-send/sw-notify-send-9999.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-misc/sw-notify-send/sw-notify-send-9999.ebuild b/x11-misc/sw-notify-send/sw-notify-send-9999.ebuild
new file mode 100644
index 000000000000..c0ac15bb55ec
--- /dev/null
+++ b/x11-misc/sw-notify-send/sw-notify-send-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+EGIT_REPO_URI="https://github.com/mgorny/tinynotify-send.git"
+inherit autotools git-r3
+
+MY_P=tinynotify-send-${PV}
+DESCRIPTION="A system-wide variant of tinynotify-send"
+HOMEPAGE="https://github.com/mgorny/tinynotify-send/"
+SRC_URI=""
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="x11-libs/libtinynotify:0=
+ ~x11-libs/libtinynotify-cli-${PV}
+ x11-libs/libtinynotify-systemwide:0="
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --disable-library
+ --disable-regular
+ --enable-system-wide
+ )
+
+ econf "${myconf[@]}"
+}