summaryrefslogtreecommitdiff
path: root/x11-misc/xbindkeys/xbindkeys-1.8.6-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xbindkeys/xbindkeys-1.8.6-r1.ebuild')
-rw-r--r--x11-misc/xbindkeys/xbindkeys-1.8.6-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-misc/xbindkeys/xbindkeys-1.8.6-r1.ebuild b/x11-misc/xbindkeys/xbindkeys-1.8.6-r1.ebuild
new file mode 100644
index 000000000000..14de366f5dcc
--- /dev/null
+++ b/x11-misc/xbindkeys/xbindkeys-1.8.6-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="Tool for launching commands on keystrokes"
+SRC_URI="http://www.nongnu.org/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.nongnu.org/xbindkeys/xbindkeys.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE="guile tk"
+
+RDEPEND="x11-libs/libX11
+ guile? ( >=dev-scheme/guile-1.8.4[deprecated] )
+ tk? ( dev-lang/tk )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-apply-mask-on-release-event-status.patch"
+)
+
+src_configure() {
+ econf \
+ $(use_enable tk) \
+ $(use_enable guile)
+}