summaryrefslogtreecommitdiff
path: root/x11-misc/xcalendar
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xcalendar')
-rw-r--r--x11-misc/xcalendar/Manifest5
-rw-r--r--x11-misc/xcalendar/files/xcalendar-4.0-clang16.patch40
-rw-r--r--x11-misc/xcalendar/files/xcalendar-4.0-implicits.patch22
-rw-r--r--x11-misc/xcalendar/files/xcalendar-4.0-motif-gentoo.diff26
-rw-r--r--x11-misc/xcalendar/xcalendar-4.0-r2.ebuild61
-rw-r--r--x11-misc/xcalendar/xcalendar-4.0-r3.ebuild68
6 files changed, 110 insertions, 112 deletions
diff --git a/x11-misc/xcalendar/Manifest b/x11-misc/xcalendar/Manifest
index c6bff90407ca..27b648ec9a55 100644
--- a/x11-misc/xcalendar/Manifest
+++ b/x11-misc/xcalendar/Manifest
@@ -1,5 +1,4 @@
-AUX xcalendar-4.0-implicits.patch 381 BLAKE2B ea6ad6617227900cf7cfd67957109d28b5e820ae87c0796367808c2442865cc94dee718ac91550f392947b77a52bca1f952e9faac14178da4b0b90cf1ede6e63 SHA512 56c68560d2f2d75b5e7427e870189771f85994e934f7d813eaa89e34002d769b9aa1e24ab49a84a395d1535963802a249171e423e47c5d0e741e1a6e9a07fbc2
-AUX xcalendar-4.0-motif-gentoo.diff 1104 BLAKE2B 3176c538d92a776faef7fbaa02985964a64609eb5e3d79edd97d095309c2fec3e6cc0f621cadc97a09ed3e10fbeb35e627214c9f7ad758486125f1d61bef3fd1 SHA512 b6f15a68e2698a1d3f8dca2be8cc0751dae447268c6bca76aeccaa5a919dc31d3675fbb8d49d7d0d3293c50835b2628346f1ea5f7eb1da6152bb1ac73282ad59
+AUX xcalendar-4.0-clang16.patch 647 BLAKE2B bf08bf26b7a0c7ec498cec5ccb3158177093dacda405f50df1d2aeb458a326dd65972955ecc271a57be858e5e61759557b5a4c6a99aec656eaf71879e7d404ea SHA512 ab71b21a38bc61abd8d82bc3c78ce20d427624b43a618177b82c6883385b87e78bfa3393eb20663e09cd0b2bd8b47891d757e25d922f2652b33841338e495a8d
DIST xcalendar-4.0+i18n.tar.gz 48635 BLAKE2B 939880d749dc36973d69d6ed6f1d2c36dfeccea6d17a9ce77bde122af8c3a19bdf683b0c1838ba11a769ef4a8977a93cc1e67c40dacac4c87d2cb7a565e3ba60 SHA512 c9b3756bf857e4956360cb3efa1e185bdc09d6053e1b8db040822c73320589ef825330184fa3a8b949f94a89a6ef56438927886b3740922a4bca7dbab9285a4d
-EBUILD xcalendar-4.0-r2.ebuild 1386 BLAKE2B a4e7a978250307438ea17034b627bb9fdf78c5869121daf52712fcbf1937052119b6ee38b67c72c8e475ff4c5c54d2a80585e8db79475aeb838109cb99e6d880 SHA512 e52301461db989a555b762d4ec4c7da7c949b9f4b186a68f6ae676e2d1e8a3c119d05f3e68bf70345bce7cdec5e8301ece489cd83cec7f881cfcfe90a446d111
+EBUILD xcalendar-4.0-r3.ebuild 1513 BLAKE2B 274afb2d4df306f4733e24e04b06ba21eb71018b92def311e43a31ddba480f50f944ada5b4f1c36261c1f96dc1872d79b3a224aba25c9077199f092ccbe3f90f SHA512 208b5c24dbe9b7ed007d338ddb9536ab71efc7553a89b9c83f4b04c3ec40b438a6731f871ce4ec69052e65894bd4c8eb982ae60e283827b8b7f94d02c398998b
MISC metadata.xml 277 BLAKE2B ebaa8353413cfc5519fce99f8627c71cf765fc6d42b42651e232274de315487c156d45dcb23a401dffb8f112600b0dadd56f93d2283ff86b4293dc5490ad4059 SHA512 c8ef9069153b124118a6be64375c6954ccc6f518a13805e4ff1c33c9cec136170132a580c4a9781930b709c93678c94d6448291625de34d18fea41bfd17f685d
diff --git a/x11-misc/xcalendar/files/xcalendar-4.0-clang16.patch b/x11-misc/xcalendar/files/xcalendar-4.0-clang16.patch
new file mode 100644
index 000000000000..9e39901f9076
--- /dev/null
+++ b/x11-misc/xcalendar/files/xcalendar-4.0-clang16.patch
@@ -0,0 +1,40 @@
+https://bugs.gentoo.org/870484
+--- a/lists.c
++++ b/lists.c
+@@ -26,4 +26,5 @@
+ #include "xcalendar.h"
+
++int is_last(LList *list);
+
+ List
+@@ -150,5 +151,5 @@
+ }
+
+-is_last(list)
++int is_last(list)
+ LList *list;
+ {
+--- a/xcalendar.c
++++ b/xcalendar.c
+@@ -1168,5 +1168,5 @@
+ int m, y;
+ {
+- register d, i;
++ int d, i;
+
+ calInit = y;
+@@ -1217,5 +1217,5 @@
+ int yr;
+ {
+- register y, d;
++ int y, d;
+
+ /*
+--- a/xcalendar.h
++++ b/xcalendar.h
+@@ -38,4 +38,5 @@
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <X11/Xos.h>
+ #include <X11/Xlib.h>
diff --git a/x11-misc/xcalendar/files/xcalendar-4.0-implicits.patch b/x11-misc/xcalendar/files/xcalendar-4.0-implicits.patch
deleted file mode 100644
index 977ca96e572f..000000000000
--- a/x11-misc/xcalendar/files/xcalendar-4.0-implicits.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Fix implicit functions declarations
-
---- xcalendar/xcalendar.h
-+++ xcalendar/xcalendar.h
-@@ -37,6 +37,7 @@
-
-
- #include <stdio.h>
-+#include <stdlib.h>
- #include <X11/Xos.h>
- #include <X11/Xlib.h>
- #include <X11/Intrinsic.h>
---- xcalendar/lists.c
-+++ xcalendar/lists.c
-@@ -25,6 +25,7 @@
-
- #include "xcalendar.h"
-
-+is_last(LList *list);
-
- List
- CreateList(length, elementSize)
diff --git a/x11-misc/xcalendar/files/xcalendar-4.0-motif-gentoo.diff b/x11-misc/xcalendar/files/xcalendar-4.0-motif-gentoo.diff
deleted file mode 100644
index a35d98bcb814..000000000000
--- a/x11-misc/xcalendar/files/xcalendar-4.0-motif-gentoo.diff
+++ /dev/null
@@ -1,26 +0,0 @@
---- xcalendar.orig/Imakefile Sat Sep 30 20:19:17 1995
-+++ xcalendar/Imakefile Tue Aug 20 08:37:48 2002
-@@ -1,18 +1,18 @@
- XCALENDAR_LIBDIR = $(LIBDIR)/xcalendar
- LIBFILES = larrow.xbm qmark.xbm quit.xbm rarrow.xbm xcalendar.hlp
- # Comment out the following two lines for the Motif version
--LOCAL_LIBRARIES = $(XAWLIB) $(XMULIB) $(XTOOLLIB) $(XLIB)
-- EXTRA_DEFINES = -DATHENA
-+#LOCAL_LIBRARIES = $(XAWLIB) $(XMULIB) $(XTOOLLIB) $(XLIB)
-+# EXTRA_DEFINES = -DATHENA
- # Uncomment the following two lines for the Motif version
--# LOCAL_LIBRARIES = -L/usr/local/Motif/lib -lXm $(XMULIB) $(XTOOLLIB) $(XLIB)
--# EXTRA_DEFINES = -I/usr/local/Motif/include
-+ LOCAL_LIBRARIES = -lXm $(XMULIB) $(XTOOLLIB) $(XLIB)
-+ EXTRA_DEFINES =
- SRCS = xcalendar.c dayeditor.c lists.c
- OBJS = xcalendar.o dayeditor.o lists.o
-
- #
- # for Internationalization
- #
--EXTRA_DEFINES = -DXI18N -DATHENA
-+#EXTRA_DEFINES = -DXI18N -DATHENA
- ##if !SharedLibXwchar
- # _UseCat($(USRLIBDIR),$(CONTRIBSRC)/lib/Xwchar,/libXwchar.a)
- # XWCHARLIB = LoaderLibPrefix _Use(-lXwchar,$(DEPXWCHARLIB))
diff --git a/x11-misc/xcalendar/xcalendar-4.0-r2.ebuild b/x11-misc/xcalendar/xcalendar-4.0-r2.ebuild
deleted file mode 100644
index a6ccd1896657..000000000000
--- a/x11-misc/xcalendar/xcalendar-4.0-r2.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit toolchain-funcs
-
-DESCRIPTION="A simple interactive calendar program with a notebook capability"
-HOMEPAGE="https://www.freebsd.org/"
-SRC_URI="ftp://daemon.jp.FreeBSD.org/pub/FreeBSD-jp/ports-jp/LOCAL_PORTS/${P}+i18n.tar.gz"
-
-LICENSE="HPND"
-SLOT="0"
-KEYWORDS="~alpha amd64 ppc ppc64 x86"
-IUSE="motif"
-
-RDEPEND="x11-libs/libX11
- x11-libs/libXmu
- x11-libs/libXt
- x11-libs/libXaw
- x11-libs/libXext"
-DEPEND="${RDEPEND}
- x11-base/xorg-proto
- >=x11-misc/imake-1.0.8-r1
- x11-misc/gccmakedep
- motif? ( >=x11-libs/motif-2.3:0 )"
-
-S=${WORKDIR}/${PN}
-PATCHES=( "${FILESDIR}"/${P}-implicits.patch )
-
-src_prepare() {
- use motif && PATCHES+=( "${FILESDIR}"/${P}-motif-gentoo.diff )
- default
- sed -e "s:%%XCALENDAR_LIBDIR%%:/usr/$(get_libdir)/xcalendar:" \
- -e "s:/usr/local/X11R5/lib/X11/:/usr/$(get_libdir)/:" \
- -i XCalendar.sed || die
-}
-
-src_configure() {
- CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
- IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf -a || die
-}
-
-src_compile() {
- emake \
- CC="$(tc-getCC)" \
- CDEBUGFLAGS="${CFLAGS}" \
- EXTRA_LDOPTIONS="${LDFLAGS}"
-}
-
-src_install() {
- dobin xcalendar
- newman xcalendar.man xcalendar.1
-
- insinto /usr/share/X11/app-defaults
- newins XCalendar.sed XCalendar
-
- insinto /usr/$(get_libdir)/xcalendar
- doins *.xbm *.hlp
-
- einstalldocs
-}
diff --git a/x11-misc/xcalendar/xcalendar-4.0-r3.ebuild b/x11-misc/xcalendar/xcalendar-4.0-r3.ebuild
new file mode 100644
index 000000000000..e400aa3e3cdc
--- /dev/null
+++ b/x11-misc/xcalendar/xcalendar-4.0-r3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Simple interactive calendar program with a notebook capability"
+HOMEPAGE="https://www.freebsd.org/"
+SRC_URI="ftp://daemon.jp.FreeBSD.org/pub/FreeBSD-jp/ports-jp/LOCAL_PORTS/${P}+i18n.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~alpha amd64 ppc ppc64 x86"
+IUSE="motif"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXt
+ motif? (
+ x11-libs/libXmu
+ x11-libs/motif
+ )
+ !motif? ( x11-libs/libXaw )"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-clang16.patch
+)
+
+src_prepare() {
+ default
+
+ sed -e "s|%%XCALENDAR_LIBDIR%%|${EPREFIX}/usr/$(get_libdir)/xcalendar|" \
+ -e "s|/usr/local/X11R5/lib/X11/|${EPREFIX}/usr/$(get_libdir)/|" \
+ < XCalendar.sed > XCalendar || die
+}
+
+src_compile() {
+ tc-export CC
+
+ if use motif; then
+ append-cppflags $($(tc-getPKG_CONFIG) --cflags x11 xmu xt || die)
+ append-libs -lXm $($(tc-getPKG_CONFIG) --libs x11 xmu xt || die)
+ else
+ append-cppflags -DATHENA $($(tc-getPKG_CONFIG) --cflags x11 xaw7 xt || die)
+ append-libs $($(tc-getPKG_CONFIG) --libs x11 xaw7 xt || die)
+ fi
+
+ emake LDLIBS="${LIBS}" -f /dev/null -E "xcalendar: dayeditor.o lists.o"
+}
+
+src_install() {
+ dobin xcalendar
+ newman xcalendar.man xcalendar.1
+
+ insinto /usr/share/X11/app-defaults
+ doins XCalendar
+
+ insinto /usr/$(get_libdir)/xcalendar
+ doins *.xbm *.hlp
+
+ einstalldocs
+}