summaryrefslogtreecommitdiff
path: root/x11-misc/xmountains/xmountains-2.9-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xmountains/xmountains-2.9-r1.ebuild')
-rw-r--r--x11-misc/xmountains/xmountains-2.9-r1.ebuild36
1 files changed, 16 insertions, 20 deletions
diff --git a/x11-misc/xmountains/xmountains-2.9-r1.ebuild b/x11-misc/xmountains/xmountains-2.9-r1.ebuild
index 712987fe73bd..3ba1649dc3fd 100644
--- a/x11-misc/xmountains/xmountains-2.9-r1.ebuild
+++ b/x11-misc/xmountains/xmountains-2.9-r1.ebuild
@@ -1,43 +1,39 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-
+EAPI=7
inherit toolchain-funcs
-MY_P=${P/-/_}
-
DESCRIPTION="Fractal terrains of snow-capped mountains near water"
HOMEPAGE="https://spbooth.github.io/xmountains/"
-SRC_URI="http://www.epcc.ed.ac.uk/~spb/${PN}/${MY_P}.tar.gz"
+SRC_URI="http://www.epcc.ed.ac.uk/~spb/${PN}/${P/-/_}.tar.gz"
LICENSE="HPND"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE=""
RDEPEND="
x11-libs/libX11
- x11-misc/xbitmaps"
-DEPEND="${RDEPEND}
- x11-base/xorg-proto"
-
+ x11-misc/xbitmaps
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.9-fno-common.patch
+ "${FILESDIR}"/${PN}-2.9-global.patch
+ "${FILESDIR}"/${PN}-2.9-main.patch
+ "${FILESDIR}"/${PN}-2.9-string.patch
+)
S=${WORKDIR}
-src_prepare() {
- default
- # add missing include for strcmp
- sed -i xmountains.c -e '1a#include <string.h> /* strcmp() */' || die
- # remove obsolete references to global.*
- sed -i Makefile.alt README -e 's|global\..||g' || die
-}
-
src_compile() {
emake \
-f Makefile.alt \
CC="$(tc-getCC)" \
CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
+ LDFLAGS="${CFLAGS} ${LDFLAGS}" \
${PN}
}