summaryrefslogtreecommitdiff
path: root/x11-misc
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/Manifest.gzbin46360 -> 46354 bytes
-rw-r--r--x11-misc/dunst/Manifest4
-rw-r--r--x11-misc/dunst/dunst-1.12.1-r1.ebuild90
-rw-r--r--x11-misc/dunst/dunst-9999.ebuild4
-rw-r--r--x11-misc/dunst/files/dunst.initd11
-rw-r--r--x11-misc/qt5ct/Manifest4
-rw-r--r--x11-misc/qt5ct/qt5ct-1.8.ebuild45
-rw-r--r--x11-misc/qt5ct/qt5ct-1.9.ebuild2
8 files changed, 109 insertions, 51 deletions
diff --git a/x11-misc/Manifest.gz b/x11-misc/Manifest.gz
index 036ec5234b3b..5f6734788532 100644
--- a/x11-misc/Manifest.gz
+++ b/x11-misc/Manifest.gz
Binary files differ
diff --git a/x11-misc/dunst/Manifest b/x11-misc/dunst/Manifest
index 3cf3d09e4a00..1fc6d0eca015 100644
--- a/x11-misc/dunst/Manifest
+++ b/x11-misc/dunst/Manifest
@@ -1,4 +1,6 @@
+AUX dunst.initd 269 BLAKE2B 0f411e08b79669e6ecd5e61060372ec6766d1f18ed6630e1172a8ae47807c73a164aeb1ea7a043bfdcb4f43e4dba5a34f98b39da340bb37f6baa1353abbe60c7 SHA512 d1aa6b9ec1820902f5dbe84ed7590d16cb9b8312aff106d8dfde9d1b70451bcd017baaf02c845847a34cb565c7b2789d6743803638158e72fe7e82b49ba693a5
DIST dunst-1.12.1.tar.gz 4654978 BLAKE2B 61dfb8c3e56367cb2afed925f4ee66891ae8edd68837d6391889972aff46683eb5fe8fbf5951e30d6be9074aa648be480847e46cc36c2db6bb4024b42c02064c SHA512 0b4ef72bde6bd4b535f11b58d8bf463df3b9b06d5e2ff40e327eb25f13771eb52c7f7aa91590c6d1228ecb3bc2105510409b6984dd45b5e747c1141f3b79b46c
+EBUILD dunst-1.12.1-r1.ebuild 1916 BLAKE2B dfeea0d0d3843882fb26a1dbeebbc245cd6a2d73431b723442c09ec34d851073fea33b938e9b69317aca0c4c918450c8026b0fc358fcfce69fa1cc51ba27aa79 SHA512 824e67d2e986ce1b18f28be122d200c4bdc35d0742ba1381fcf5c8ffdc9ee1a67f647d388ff3d65e6cd2171bdb2cb2bc0be7cf2934285c9f3375364b4abd1403
EBUILD dunst-1.12.1.ebuild 1848 BLAKE2B 021bd5b9642dfc767c9456181ac18a381f607492eb20328db0607cdfa51d6077360cc7bdef834d5bcd7db2b6e6843bbcfe523f71af81a6cb7a584baf251bd863 SHA512 f8779bf9eda90829f29b48c63fa94a70cd4907def66a0e7f687ef5da0451905c470be564a9a88afba9bca78d8e90b43ae7ce31895e12f5ce180ba12983f3ed8d
-EBUILD dunst-9999.ebuild 1773 BLAKE2B bd51fc291f84d52f6b6791479aa23117c907fd42f065bab30dac19b3d7d8147fd6e4d37682f198d6475f7900938c67d4fcbc42f6f099a93b27a813a9a2247d23 SHA512 deb41c8b95d714f0eef1360e93f172a3930600254f8f872c311ad3d9186973633490511a4b2bee18b11bf045da4a4b7e1eb4a0ff67993c8adcf6ec5860bbb232
+EBUILD dunst-9999.ebuild 1839 BLAKE2B c7f0b60d826f555e1415b3eff5caa276d9da8a6393226a9e698ef194bd201d700f730a1b7293d2138b60319190b751838868bcaa9ea11e3939245d7005172a78 SHA512 0774a06de0ad17b4454c6cd2b0636795d7dc136ab2698c0e7ac97556e20e04c719ca29be9141523071a9155ad1f230fbc14f58cc0ecb4970faf56edba8098d40
MISC metadata.xml 583 BLAKE2B 0e304f035c74e14c1551e0e15eafac158cded052a39b893ab63b72f700a3d151fe048db153b00a1c98145261e8d6f56e609e215e95ff75de091d6f33156c9f14 SHA512 31932adf73148096301e796a0320332efd87f5b855d51618c81bb661611ef51d151ed2ea9575e3e64702368ca0791a9a5b9c8d2b6c036e1d11ce8bf04b7dc151
diff --git a/x11-misc/dunst/dunst-1.12.1-r1.ebuild b/x11-misc/dunst/dunst-1.12.1-r1.ebuild
new file mode 100644
index 000000000000..f5a7861e403a
--- /dev/null
+++ b/x11-misc/dunst/dunst-1.12.1-r1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd toolchain-funcs
+
+DESCRIPTION="Lightweight replacement for common notification daemons"
+HOMEPAGE="https://dunst-project.org/ https://github.com/dunst-project/dunst"
+SRC_URI="https://github.com/dunst-project/dunst/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+completions +dunstify wayland +X +xdg"
+
+DEPEND="
+ dev-libs/glib:2
+ sys-apps/dbus
+ x11-libs/cairo[X?,glib]
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango[X?]
+ dunstify? ( x11-libs/libnotify )
+ wayland? ( dev-libs/wayland )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXScrnSaver
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ )
+ xdg? ( x11-misc/xdg-utils )
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ dev-lang/perl
+ virtual/pkgconfig
+ wayland? ( dev-libs/wayland-protocols )
+"
+
+REQUIRED_USE="|| ( wayland X )"
+
+src_prepare() {
+ default
+
+ # Respect users CFLAGS
+ sed -e 's/-Os//' -i config.mk || die
+
+ # Use correct path for dbus and system unit
+ sed -e "s|##PREFIX##|${EPREFIX}/usr|" -i dunst.systemd.service.in || die
+ sed -e "s|##PREFIX##|${EPREFIX}/usr|" -i org.knopwob.dunst.service.in || die
+}
+
+src_configure() {
+ tc-export CC PKG_CONFIG
+
+ default
+}
+
+src_compile() {
+ local myemakeargs=(
+ DUNSTIFY="$(usex dunstify 1 0)"
+ SYSCONFDIR="${EPREFIX}/etc/xdg"
+ SYSTEMD="0"
+ WAYLAND="$(usex wayland 1 0)"
+ X11="$(usex X 1 0)"
+ )
+
+ emake "${myemakeargs[@]}"
+}
+
+src_install() {
+ local myemakeargs=(
+ COMPLETIONS="$(usex completions 1 0)"
+ DUNSTIFY="$(usex dunstify 1 0)"
+ PREFIX="${ED}/usr"
+ SYSCONFDIR="${ED}/etc/xdg"
+ SYSTEMD="0"
+ WAYLAND="$(usex wayland 1 0)"
+ X11="$(usex X 1 0)"
+ )
+
+ emake "${myemakeargs[@]}" install
+
+ exeinto /etc/user/init.d
+ newexe "${FILESDIR}/dunst.initd" dunst
+ systemd_newuserunit dunst.systemd.service.in dunst.service
+}
diff --git a/x11-misc/dunst/dunst-9999.ebuild b/x11-misc/dunst/dunst-9999.ebuild
index 38f2b2385cea..ffbf4be52163 100644
--- a/x11-misc/dunst/dunst-9999.ebuild
+++ b/x11-misc/dunst/dunst-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -84,5 +84,7 @@ src_install() {
emake "${myemakeargs[@]}" install
+ exeinto /etc/user/init.d
+ newexe "${FILESDIR}/dunst.initd" dunst
systemd_newuserunit dunst.systemd.service.in dunst.service
}
diff --git a/x11-misc/dunst/files/dunst.initd b/x11-misc/dunst/files/dunst.initd
new file mode 100644
index 000000000000..c5bfa4cc8bc7
--- /dev/null
+++ b/x11-misc/dunst/files/dunst.initd
@@ -0,0 +1,11 @@
+#!/sbin/openrc-run
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+depend() {
+ need dbus
+}
+
+export DBUS_SESSION_BUS_ADDRESS="${XDG_RUNTIME_DIR}/bus"
+supervisor=supervise-daemon
+command="/usr/bin/dunst"
diff --git a/x11-misc/qt5ct/Manifest b/x11-misc/qt5ct/Manifest
index 27242daa6401..fed180fca01c 100644
--- a/x11-misc/qt5ct/Manifest
+++ b/x11-misc/qt5ct/Manifest
@@ -1,5 +1,3 @@
-DIST qt5ct-1.8.tar.bz2 85945 BLAKE2B 0a882a076eb1013c4196e9067f7ed135b0f86c2850071de4945bb17053618a605ca412fbc1c7a87a6e00ee051f4fb5f0d31754490aa51abe472c72a6918088c9 SHA512 5417850fb2bad4faaed59c8af61bec04c1ee7fefe8495286571e257b2f68cd417d36439c66fcfac28bb735c753a4ca4cec327b74e97e5ce8c2d4e36b3e4fba28
DIST qt5ct-1.9.tar.bz2 87416 BLAKE2B 72aa7055c4f7ae901001c343e2c2ad8a21568e493277f9b4b3b94497aa7bce252c6c72426d86c4427cf7545c6bfcf650f1587ebfe40842fc848115d226ec817f SHA512 8f0ed517c6b6f42eb75ac20a629cae6230846f5bdcb0a5446f52f5dc46812ee0278d095433804cd3c25c650d1737eb02d2ab2bd88fea65efa2e2ccb8c60de192
-EBUILD qt5ct-1.8.ebuild 940 BLAKE2B be980603e619c1cfe6e03097c22b1ea91a980a1831ab54e7ac38dccf6f1fdb375bce7c8bd53e1a1ada78d352437fdfe6c6c3753a31aa7e63bb2b1c6e0ce09adb SHA512 c201d72b130955333cdeb4ebbd6d0f61bc8258656812f277a04f7d7f5058a530a7e34b2e114165403dbc6eeb78677f2f61d0229fed1708d25a34eb1b67d9644d
-EBUILD qt5ct-1.9.ebuild 942 BLAKE2B ad352153f8905dca934008d3323213808ae0a364f9bf61c1398bdca5662b0c074c877a500b133e4dff441a74b2b2d03aa574f9b7b3ef05c822a10f1a07c934d8 SHA512 b29882a84e9551326e9999abec230df7051f5658f84413f1f8c29556aeac90330ef74099a00d337af46413e2cc19b94dce56a5b0585f2ea276a013a6f9bba709
+EBUILD qt5ct-1.9.ebuild 940 BLAKE2B 5ff6465b84f7714ad1b31380a88e1afa38edcf221c3c61db6fe00bb011677dcc70274c596cefa359571f010fee6c8b44f7deee1220c0cbd0b97f151e400d904d SHA512 75a975b86a4598d4eceacb77222b44e18312e7432eb89b26f5f6f865a93af140b72d1ada107c6ed724bba02698c98d7229893d05a326bed4d23cbfafec913837
MISC metadata.xml 482 BLAKE2B fac0c00072791bfee45fe52707734e35a18e58f21704b6897bc315ffbd4db50f2fcc058586d04c2459d39d040cd55ef3bd328b12d66c9b35f61cf985462f4d2a SHA512 6c0a13ee72cfdb1415899864758870c837adc76471358ec61aa661348caf4dccad6398a0f25a1e4bd638b7d01eeee484b7350726c0626cf991db7cd32ccc518c
diff --git a/x11-misc/qt5ct/qt5ct-1.8.ebuild b/x11-misc/qt5ct/qt5ct-1.8.ebuild
deleted file mode 100644
index 8be1a39d4b3c..000000000000
--- a/x11-misc/qt5ct/qt5ct-1.8.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Qt5 configuration tool, similar to qtconfig for Qt4"
-HOMEPAGE="https://sourceforge.net/projects/qt5ct/"
-SRC_URI="https://download.sourceforge.net/qt5ct/${P}.tar.bz2"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~ppc64 x86"
-
-RDEPEND="
- dev-qt/qtconcurrent:5
- dev-qt/qtcore:5
- dev-qt/qtdbus:5
- dev-qt/qtgui:5=[dbus]
- dev-qt/qtwidgets:5
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-qt/linguist-tools:5
- dev-qt/qtpaths:5
-"
-
-src_install() {
- cmake_src_install
-
- newenvd - 98qt5ct <<< 'QT_QPA_PLATFORMTHEME=qt5ct'
-}
-
-pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- ewarn "qt5ct configuration won't be applied to the currently running sessions."
- ewarn "Please relogin."
- fi
- if ! has_version 'dev-qt/qtsvg:5'; then
- elog
- elog "For SVG icon themes, please install 'dev-qt/qtsvg:5'."
- elog
- fi
-}
diff --git a/x11-misc/qt5ct/qt5ct-1.9.ebuild b/x11-misc/qt5ct/qt5ct-1.9.ebuild
index 94c08b320c08..091f5edf48ae 100644
--- a/x11-misc/qt5ct/qt5ct-1.9.ebuild
+++ b/x11-misc/qt5ct/qt5ct-1.9.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://download.sourceforge.net/qt5ct/${P}.tar.bz2"
LICENSE="BSD-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+KEYWORDS="amd64 ~arm ~ppc64 x86"
RDEPEND="
dev-qt/qtconcurrent:5