summaryrefslogtreecommitdiff
path: root/x11-misc
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/Manifest.gzbin46360 -> 46359 bytes
-rw-r--r--x11-misc/dunst/Manifest4
-rw-r--r--x11-misc/dunst/dunst-1.12.1-r1.ebuild90
-rw-r--r--x11-misc/dunst/dunst-9999.ebuild4
-rw-r--r--x11-misc/dunst/files/dunst.initd11
5 files changed, 107 insertions, 2 deletions
diff --git a/x11-misc/Manifest.gz b/x11-misc/Manifest.gz
index 036ec5234b3b..0db0f8bd5e4d 100644
--- a/x11-misc/Manifest.gz
+++ b/x11-misc/Manifest.gz
Binary files differ
diff --git a/x11-misc/dunst/Manifest b/x11-misc/dunst/Manifest
index 3cf3d09e4a00..1fc6d0eca015 100644
--- a/x11-misc/dunst/Manifest
+++ b/x11-misc/dunst/Manifest
@@ -1,4 +1,6 @@
+AUX dunst.initd 269 BLAKE2B 0f411e08b79669e6ecd5e61060372ec6766d1f18ed6630e1172a8ae47807c73a164aeb1ea7a043bfdcb4f43e4dba5a34f98b39da340bb37f6baa1353abbe60c7 SHA512 d1aa6b9ec1820902f5dbe84ed7590d16cb9b8312aff106d8dfde9d1b70451bcd017baaf02c845847a34cb565c7b2789d6743803638158e72fe7e82b49ba693a5
DIST dunst-1.12.1.tar.gz 4654978 BLAKE2B 61dfb8c3e56367cb2afed925f4ee66891ae8edd68837d6391889972aff46683eb5fe8fbf5951e30d6be9074aa648be480847e46cc36c2db6bb4024b42c02064c SHA512 0b4ef72bde6bd4b535f11b58d8bf463df3b9b06d5e2ff40e327eb25f13771eb52c7f7aa91590c6d1228ecb3bc2105510409b6984dd45b5e747c1141f3b79b46c
+EBUILD dunst-1.12.1-r1.ebuild 1916 BLAKE2B dfeea0d0d3843882fb26a1dbeebbc245cd6a2d73431b723442c09ec34d851073fea33b938e9b69317aca0c4c918450c8026b0fc358fcfce69fa1cc51ba27aa79 SHA512 824e67d2e986ce1b18f28be122d200c4bdc35d0742ba1381fcf5c8ffdc9ee1a67f647d388ff3d65e6cd2171bdb2cb2bc0be7cf2934285c9f3375364b4abd1403
EBUILD dunst-1.12.1.ebuild 1848 BLAKE2B 021bd5b9642dfc767c9456181ac18a381f607492eb20328db0607cdfa51d6077360cc7bdef834d5bcd7db2b6e6843bbcfe523f71af81a6cb7a584baf251bd863 SHA512 f8779bf9eda90829f29b48c63fa94a70cd4907def66a0e7f687ef5da0451905c470be564a9a88afba9bca78d8e90b43ae7ce31895e12f5ce180ba12983f3ed8d
-EBUILD dunst-9999.ebuild 1773 BLAKE2B bd51fc291f84d52f6b6791479aa23117c907fd42f065bab30dac19b3d7d8147fd6e4d37682f198d6475f7900938c67d4fcbc42f6f099a93b27a813a9a2247d23 SHA512 deb41c8b95d714f0eef1360e93f172a3930600254f8f872c311ad3d9186973633490511a4b2bee18b11bf045da4a4b7e1eb4a0ff67993c8adcf6ec5860bbb232
+EBUILD dunst-9999.ebuild 1839 BLAKE2B c7f0b60d826f555e1415b3eff5caa276d9da8a6393226a9e698ef194bd201d700f730a1b7293d2138b60319190b751838868bcaa9ea11e3939245d7005172a78 SHA512 0774a06de0ad17b4454c6cd2b0636795d7dc136ab2698c0e7ac97556e20e04c719ca29be9141523071a9155ad1f230fbc14f58cc0ecb4970faf56edba8098d40
MISC metadata.xml 583 BLAKE2B 0e304f035c74e14c1551e0e15eafac158cded052a39b893ab63b72f700a3d151fe048db153b00a1c98145261e8d6f56e609e215e95ff75de091d6f33156c9f14 SHA512 31932adf73148096301e796a0320332efd87f5b855d51618c81bb661611ef51d151ed2ea9575e3e64702368ca0791a9a5b9c8d2b6c036e1d11ce8bf04b7dc151
diff --git a/x11-misc/dunst/dunst-1.12.1-r1.ebuild b/x11-misc/dunst/dunst-1.12.1-r1.ebuild
new file mode 100644
index 000000000000..f5a7861e403a
--- /dev/null
+++ b/x11-misc/dunst/dunst-1.12.1-r1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd toolchain-funcs
+
+DESCRIPTION="Lightweight replacement for common notification daemons"
+HOMEPAGE="https://dunst-project.org/ https://github.com/dunst-project/dunst"
+SRC_URI="https://github.com/dunst-project/dunst/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+completions +dunstify wayland +X +xdg"
+
+DEPEND="
+ dev-libs/glib:2
+ sys-apps/dbus
+ x11-libs/cairo[X?,glib]
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango[X?]
+ dunstify? ( x11-libs/libnotify )
+ wayland? ( dev-libs/wayland )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXScrnSaver
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ )
+ xdg? ( x11-misc/xdg-utils )
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ dev-lang/perl
+ virtual/pkgconfig
+ wayland? ( dev-libs/wayland-protocols )
+"
+
+REQUIRED_USE="|| ( wayland X )"
+
+src_prepare() {
+ default
+
+ # Respect users CFLAGS
+ sed -e 's/-Os//' -i config.mk || die
+
+ # Use correct path for dbus and system unit
+ sed -e "s|##PREFIX##|${EPREFIX}/usr|" -i dunst.systemd.service.in || die
+ sed -e "s|##PREFIX##|${EPREFIX}/usr|" -i org.knopwob.dunst.service.in || die
+}
+
+src_configure() {
+ tc-export CC PKG_CONFIG
+
+ default
+}
+
+src_compile() {
+ local myemakeargs=(
+ DUNSTIFY="$(usex dunstify 1 0)"
+ SYSCONFDIR="${EPREFIX}/etc/xdg"
+ SYSTEMD="0"
+ WAYLAND="$(usex wayland 1 0)"
+ X11="$(usex X 1 0)"
+ )
+
+ emake "${myemakeargs[@]}"
+}
+
+src_install() {
+ local myemakeargs=(
+ COMPLETIONS="$(usex completions 1 0)"
+ DUNSTIFY="$(usex dunstify 1 0)"
+ PREFIX="${ED}/usr"
+ SYSCONFDIR="${ED}/etc/xdg"
+ SYSTEMD="0"
+ WAYLAND="$(usex wayland 1 0)"
+ X11="$(usex X 1 0)"
+ )
+
+ emake "${myemakeargs[@]}" install
+
+ exeinto /etc/user/init.d
+ newexe "${FILESDIR}/dunst.initd" dunst
+ systemd_newuserunit dunst.systemd.service.in dunst.service
+}
diff --git a/x11-misc/dunst/dunst-9999.ebuild b/x11-misc/dunst/dunst-9999.ebuild
index 38f2b2385cea..ffbf4be52163 100644
--- a/x11-misc/dunst/dunst-9999.ebuild
+++ b/x11-misc/dunst/dunst-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -84,5 +84,7 @@ src_install() {
emake "${myemakeargs[@]}" install
+ exeinto /etc/user/init.d
+ newexe "${FILESDIR}/dunst.initd" dunst
systemd_newuserunit dunst.systemd.service.in dunst.service
}
diff --git a/x11-misc/dunst/files/dunst.initd b/x11-misc/dunst/files/dunst.initd
new file mode 100644
index 000000000000..c5bfa4cc8bc7
--- /dev/null
+++ b/x11-misc/dunst/files/dunst.initd
@@ -0,0 +1,11 @@
+#!/sbin/openrc-run
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+depend() {
+ need dbus
+}
+
+export DBUS_SESSION_BUS_ADDRESS="${XDG_RUNTIME_DIR}/bus"
+supervisor=supervise-daemon
+command="/usr/bin/dunst"