summaryrefslogtreecommitdiff
path: root/x11-plugins/i8krellm/i8krellm-2.5-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/i8krellm/i8krellm-2.5-r3.ebuild')
-rw-r--r--x11-plugins/i8krellm/i8krellm-2.5-r3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-plugins/i8krellm/i8krellm-2.5-r3.ebuild b/x11-plugins/i8krellm/i8krellm-2.5-r3.ebuild
new file mode 100644
index 000000000000..5bdff0ee4969
--- /dev/null
+++ b/x11-plugins/i8krellm/i8krellm-2.5-r3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="GKrellM2 Plugin for the Dell Inspiron and Latitude notebooks"
+SRC_URI="http://www.coding-zone.com/${P}.tar.gz"
+HOMEPAGE="http://www.coding-zone.com/?page=i8krellm"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-admin/gkrellm:2[X]
+ >=app-laptop/i8kutils-1.5"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-Respect-LDFLAGS.patch
+ "${FILESDIR}"/${P}-r3-makefile-fixes.patch
+ "${FILESDIR}"/${P}-r3-rm-gkrellm1-support.patch
+)
+
+src_compile() {
+ tc-export PKG_CONFIG
+ emake CC="$(tc-getCC)"
+}