summaryrefslogtreecommitdiff
path: root/x11-plugins/wmSMPmon/wmSMPmon-3.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmSMPmon/wmSMPmon-3.1-r2.ebuild')
-rw-r--r--x11-plugins/wmSMPmon/wmSMPmon-3.1-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-plugins/wmSMPmon/wmSMPmon-3.1-r2.ebuild b/x11-plugins/wmSMPmon/wmSMPmon-3.1-r2.ebuild
new file mode 100644
index 000000000000..5ec664e00fd4
--- /dev/null
+++ b/x11-plugins/wmSMPmon/wmSMPmon-3.1-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="SMP system monitor dockapp"
+HOMEPAGE="https://www.dockapps.net/wmsmpmon"
+SRC_URI="https://www.dockapps.net/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+DOCS=( ../Changelog )
+
+S="${WORKDIR}/${P}/${PN}"
+
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+
+src_compile() {
+ emake CC="$(tc-getCC)" LIBDIR="/usr/$(get_libdir)"
+}