summaryrefslogtreecommitdiff
path: root/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild')
-rw-r--r--x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild b/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild
index ffc03d2648bb..d902e3de4a33 100644
--- a/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild
+++ b/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=2
+inherit eutils
DESCRIPTION="DockApp monitors the temperature and Speedstep features in ACPI-based systems"
HOMEPAGE="http://www.vrlteam.org/wmacpimon/"
@@ -18,18 +19,18 @@ RDEPEND="x11-libs/libX11
DEPEND="${RDEPEND}
x11-base/xorg-proto"
-PATCHES=(
+src_prepare() {
# patch wmacpimon.c file to set default path for
# wmacpimon.prc to /var/tmp/
- "${FILESDIR}/wmacpimon.c.patch"
+ epatch "${FILESDIR}"/wmacpimon.c.patch
# fix LDFLAGS ordering. See bug #248618.
# fix LDFLAGS ordering again and other stuff. See bug #336091.
- "${FILESDIR}/Makefile.patch"
-)
+ epatch "${FILESDIR}"/Makefile.patch
+}
src_install() {
- dobin wmacpimond wmacpimon
+ dobin wmacpimond wmacpimon || die "dobin failed."
dodoc AUTHORS ChangeLog README
newinitd "${FILESDIR}"/wmacpimon.initscript wmacpimon
}