summaryrefslogtreecommitdiff
path: root/x11-plugins/wmcms
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmcms')
-rw-r--r--x11-plugins/wmcms/Manifest3
-rw-r--r--x11-plugins/wmcms/files/wmcms-0.3.5-c99.patch51
-rw-r--r--x11-plugins/wmcms/wmcms-0.3.5-r5.ebuild (renamed from x11-plugins/wmcms/wmcms-0.3.5-r4.ebuild)17
3 files changed, 58 insertions, 13 deletions
diff --git a/x11-plugins/wmcms/Manifest b/x11-plugins/wmcms/Manifest
index 8f9a881747e8..6f3ec3eb8b45 100644
--- a/x11-plugins/wmcms/Manifest
+++ b/x11-plugins/wmcms/Manifest
@@ -1,4 +1,5 @@
+AUX wmcms-0.3.5-c99.patch 1365 BLAKE2B 52f17a806e0aa5a443f59bf7208f15940529750fe6585cc12a7730e56e20565b86f721577e215ce4e48699047f8549b14a5ecaa086a2fb1ae07c2ad9ed69e6fa SHA512 b7dbb07c93a12338f78ae0205eea47196056a0dbad4cc87307f40d9d271d50557c6bd9ef0fd9cf0aaba6b9fac901c662e079c67dec2ab4a1644f75e67358f6e8
AUX wmcms-0.3.5-s4t4n.patch 8562 BLAKE2B d1b99dc03a8dd0fd2f1e5d387ee8b763a0b1633199c20ab231fa8496a253f9124ad7508bd66cf742660b7aa9ddca16b5eaa887f08ddb4e8de0dd10b7cf490370 SHA512 ad25dead5271907845ae96efec52844de1005f31ddbf4d2e43996633ef8c54c89f9137421b019079462227a16052df950c7f589d112815c8b02b435f863e8b09
DIST wmcms-0.3.5.tar.gz 19855 BLAKE2B ac97dc403e6adeebc85b386ae7c78a8537c33858950f41059aadb750909b22fabef5bed3114e9552b381d3fb9d603e90236c88a614ee168a46214f64b9ca50f5 SHA512 ef57e6b278c14163de0792e6af8be40ef721020594fb2871aad34543471869ecf468210c173861a93b4f22e1dfca8f1e4254aec6508adfdf143f3a0f1a49f549
-EBUILD wmcms-0.3.5-r4.ebuild 752 BLAKE2B 8f13e3eaf86f6ff5ee644ff152b5d6abea58f8c2d34256b35505ea59f0632ffafb994640b3b1cf8602f9e04856cd08c1859f218981441c58d76962dc2056c168 SHA512 0790ae9be3951f636fceddb50dce8a5023ca580f6371122d159819d50f47e808eb24685e52f6df63859cf9ba4988a7155c5907674ff7f305d98e169fb2a78421
+EBUILD wmcms-0.3.5-r5.ebuild 571 BLAKE2B 7793aa388faae3b418f76eaa2d70cf23d005abaa3ab63c569edc9f94fbdc0ed890cc4bb261118be29af4fa3869b6839b8da452aba479e5d23908d5979162e237 SHA512 d0847636b1ab2d13322748490f94fb9868517cd272a7fa7ab3356a3457bc738b5ab1e691f1ec57b1438c02124620571abf5e4f2b0445c158965b0d724b1bcd7d
MISC metadata.xml 250 BLAKE2B 3d69a837b82fe334630573d6bf123718a3eac254377bc2ca86a2268f210cbcef9922db631e91954bceacc28828b54ad567d0568a4df655545ac56a4a54151d76 SHA512 ee587c14474743ca118c5468d1cd04ce5e3533ea29550ae74a7d517f092c895fa18c7edc7e9ffe7757b62c214dda7abf5352ee838a6dbd7d1079d60d2762732f
diff --git a/x11-plugins/wmcms/files/wmcms-0.3.5-c99.patch b/x11-plugins/wmcms/files/wmcms-0.3.5-c99.patch
new file mode 100644
index 000000000000..6df3bb9dd1cf
--- /dev/null
+++ b/x11-plugins/wmcms/files/wmcms-0.3.5-c99.patch
@@ -0,0 +1,51 @@
+Fix C099 bugs - correct types of static values,
+inclyde correct headers.
+Fold seds from old ebuild.
+Remove CC and CFLAGS from Makefile - toolchain provides
+https://bugs.gentoo.org/874483
+https://bugs.gentoo.org/919218
+--- a/Makefile 2025-02-24 22:58:37.620418861 +0400
++++ b/Makefile 2025-02-24 22:59:58.108959699 +0400
+@@ -1,7 +1,5 @@
+-CC = gcc
+ LIBS = -lXext -lX11 -L/usr/X11R6/lib -lXpm -ldockapp
+ SRCS = wmcms.c
+-CFLAGS = -g -O2
+
+ all: wmcms
+
+@@ -9,7 +7,7 @@
+ rm -f wmcms
+
+ wmcms : $(SRCS) wmcms.xpm
+- $(CC) $(CFLAGS) $(SRCS) $(INC) -o wmcms $(LIBS)
++ $(CC) $(CFLAGS) $(SRCS) $(INC) ${LDFLAGS} -o wmcms $(LIBS)
+
+ install : all
+ install -c -s wmcms /usr/local/bin
+diff '--color=auto' -ru wmcms-0.3.5.old/wmcms.c wmcms-0.3.5/wmcms.c
+--- wmcms-0.3.5.old/wmcms.c 2025-02-24 22:58:37.620418861 +0400
++++ wmcms-0.3.5/wmcms.c 2025-02-24 22:59:37.916610009 +0400
+@@ -18,9 +18,10 @@
+
+ #include <stdio.h>
+ #include <unistd.h>
+-#include <dockapp.h>
++#include <string.h>
++#include <libdockapp/dockapp.h>
+ #include "state_linux_2.6.h"
+ #include "state_linux_2.4.h"
+ #include "wmcms.xpm"
+
+ char *displayName = "";
+@@ -133,8 +144,8 @@
+ }
+ int main (int argc, char **argv)
+ {
+- static unsigned b_width = 64;
+- static unsigned b_height = 137;
++ static unsigned short b_width = 64;
++ static unsigned short b_height = 137;
+
+ int cpu_total;
+ int old_cpu_user;
diff --git a/x11-plugins/wmcms/wmcms-0.3.5-r4.ebuild b/x11-plugins/wmcms/wmcms-0.3.5-r5.ebuild
index af360d3fe27e..9cbd9d6ad209 100644
--- a/x11-plugins/wmcms/wmcms-0.3.5-r4.ebuild
+++ b/x11-plugins/wmcms/wmcms-0.3.5-r5.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit toolchain-funcs
@@ -17,19 +17,12 @@ DEPEND=">=x11-libs/libdockapp-0.7:="
PATCHES=(
"${FILESDIR}"/${P}-s4t4n.patch
+ "${FILESDIR}"/${P}-c99.patch
)
-src_prepare() {
- default
-
- # Respect LDFLAGS, see bug #335031
- sed -e 's/ -o wmcms/ ${LDFLAGS} -o wmcms/' -i Makefile || die
-
- sed -e 's#<dockapp.h>#<libdockapp/dockapp.h>#' -i *.c || die
-}
-
src_compile() {
- emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)"
+ tc-export CC
+ default
}
src_install() {