summaryrefslogtreecommitdiff
path: root/x11-plugins/wmpop3/wmpop3-0.5.6a-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmpop3/wmpop3-0.5.6a-r2.ebuild')
-rw-r--r--x11-plugins/wmpop3/wmpop3-0.5.6a-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-plugins/wmpop3/wmpop3-0.5.6a-r2.ebuild b/x11-plugins/wmpop3/wmpop3-0.5.6a-r2.ebuild
new file mode 100644
index 000000000000..7571699de25f
--- /dev/null
+++ b/x11-plugins/wmpop3/wmpop3-0.5.6a-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Dockapp for checking pop3 accounts"
+HOMEPAGE="https://www.dockapps.net/wmpop3"
+SRC_URI="https://www.dockapps.net/download/${P/wmpop3/WMPop3}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+
+DEPEND="x11-wm/windowmaker
+ x11-libs/libXpm"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-list.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+ )
+
+src_prepare() {
+ sed -e "s|cc |$(tc-getCC) |" \
+ -e "s|-O2|${CFLAGS}|" \
+ -e "s|-o wmpop3|${LDFLAGS} -o wmpop3|" \
+ -i ${PN}/Makefile || die
+
+ default
+}
+
+src_compile() {
+ emake -C wmpop3
+}
+
+src_install() {
+ dobin wmpop3/wmpop3
+ dodoc CHANGE_LOG README
+}