summaryrefslogtreecommitdiff
path: root/x11-plugins/wmxres/wmxres-1.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmxres/wmxres-1.2-r1.ebuild')
-rw-r--r--x11-plugins/wmxres/wmxres-1.2-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-plugins/wmxres/wmxres-1.2-r1.ebuild b/x11-plugins/wmxres/wmxres-1.2-r1.ebuild
new file mode 100644
index 000000000000..cd415d8686c2
--- /dev/null
+++ b/x11-plugins/wmxres/wmxres-1.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Dock application to select your display mode among those possible"
+HOMEPAGE="http://yalla.free.fr/wn"
+SRC_URI="http://yalla.free.fr/wn/${PN}-1.1-0.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm
+ x11-libs/libXxf86vm"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/libXxf86dga"
+
+S="${WORKDIR}/${PN}.app"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-debian-1.1-1.2.patch
+ "${FILESDIR}"/${PN}-1.2-r1-fix-build-system.patch
+)
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin ${PN}/${PN}
+ doman ${PN}.1
+}