summaryrefslogtreecommitdiff
path: root/x11-plugins
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/Manifest.gzbin28052 -> 28051 bytes
-rw-r--r--x11-plugins/pidgin-musictracker/Manifest3
-rw-r--r--x11-plugins/pidgin-musictracker/files/pidgin-musictracker-0.4.22-fno-common.patch12
-rw-r--r--x11-plugins/pidgin-musictracker/pidgin-musictracker-0.4.22.ebuild17
-rw-r--r--x11-plugins/pidgin-telegram/Manifest5
-rw-r--r--x11-plugins/pidgin-telegram/files/pidgin-telegram-1.4.3-clang.patch101
-rw-r--r--x11-plugins/pidgin-telegram/pidgin-telegram-1.4.4.ebuild56
-rw-r--r--x11-plugins/pidgin-telegram/pidgin-telegram-1.4.6.ebuild2
-rw-r--r--x11-plugins/vicious/Manifest2
-rw-r--r--x11-plugins/vicious/vicious-2.5.0.ebuild2
10 files changed, 28 insertions, 172 deletions
diff --git a/x11-plugins/Manifest.gz b/x11-plugins/Manifest.gz
index 6f4a8a419622..d0c6d2481d9d 100644
--- a/x11-plugins/Manifest.gz
+++ b/x11-plugins/Manifest.gz
Binary files differ
diff --git a/x11-plugins/pidgin-musictracker/Manifest b/x11-plugins/pidgin-musictracker/Manifest
index 152fa7ad7a67..eda3c1f955a9 100644
--- a/x11-plugins/pidgin-musictracker/Manifest
+++ b/x11-plugins/pidgin-musictracker/Manifest
@@ -1,3 +1,4 @@
+AUX pidgin-musictracker-0.4.22-fno-common.patch 364 BLAKE2B a7a73a8b3cee7711051b436ec2f823e71526b901a84539e7f0ceacf10578b008899803045b4e7601df4bbd11d880d73816ef834a67e267a234ba1934b669d07e SHA512 f786d723273fc173eb9d442df355bf3a5f49925acbe476513f9583d00b410d5a38fbb10162a996a27e84eb0b610fbf3483d8370f6f220e9de07a17ec726f361e
DIST pidgin-musictracker-0.4.22.tar.bz2 727051 BLAKE2B a9d265ca0305b9b80b2354e39469be585cedf0a0e0226fcd23b3c6c9250f9b01a7882c55dc74acc1ce05effb7af954777eadb2192bc14b3846b1152e745aa359 SHA512 5a39311c4b4c8ceb4d2535b4aacb1427d9e1b004d34bc342ae3da6c60bd50e0b58a89ef52d02f3a431e8839cc647e23082bdf18b250135e95da5e6ea78c7b790
-EBUILD pidgin-musictracker-0.4.22.ebuild 819 BLAKE2B 32da00e6cceff4bc6987c2ed1ef8257cca472a715190924df0ea8d81265f751a717fa13b673ffb939397c73206041d42402fc9a0270d02e753ebbebc550a3263 SHA512 e5ac427b75a7b37e9a0feb52f48f25222d8503c2ea3c007d37ec507cf25d4d595ca520ccd3360de4ec7476143aed5b6e8cd69e2a4d5b11808cb6d6c37847f221
+EBUILD pidgin-musictracker-0.4.22.ebuild 816 BLAKE2B d8034b07f3f81067f451fa908189e8a0d1173b71a6bdc4e864164eb7dab0bfd0e8ec1404e1ce139037821f63d93ec90fbd0217bef5104080ed1ff2e32c6bb26b SHA512 6017b667f2948e5eec80b33df1e566834b11c5a732240e38105eb5a34f390795347f474c8c607e0a6a172115a76678bcabd0787d10cee8df40c14e1aefd08ef2
MISC metadata.xml 256 BLAKE2B 5eb0f6ea34d849011bd22ef060f43a9a7eed95132388e430b0db91b1cb2b40e8ad870869cc1ef7924cdf11445fd424f545cb7c78c5521f6d35379aa839e5e426 SHA512 dcde2fd66ef9199ac5db90e70bc8fea45fa4b3551ba53cb19e8d31e5ff6af4b5ff2be7eb88fe936c32e5d7a4be22cfab843501a30d1ba9ba963bcf7d3d5d1a47
diff --git a/x11-plugins/pidgin-musictracker/files/pidgin-musictracker-0.4.22-fno-common.patch b/x11-plugins/pidgin-musictracker/files/pidgin-musictracker-0.4.22-fno-common.patch
new file mode 100644
index 000000000000..0378523c3469
--- /dev/null
+++ b/x11-plugins/pidgin-musictracker/files/pidgin-musictracker-0.4.22-fno-common.patch
@@ -0,0 +1,12 @@
+https://bugs.gentoo.org/717424
+--- a/src/utils.h
++++ b/src/utils.h
+@@ -21,7 +21,7 @@ pcre* regex(const char* pattern, int options);
+ int capture(pcre* re, const char *text, int len, ...);
+
+ #ifndef WIN32
+-DBusGConnection *connection;
++extern DBusGConnection *connection;
+ gboolean dbus_g_init_connection(void);
+ gboolean dbus_g_running(const char *name);
+ #endif
diff --git a/x11-plugins/pidgin-musictracker/pidgin-musictracker-0.4.22.ebuild b/x11-plugins/pidgin-musictracker/pidgin-musictracker-0.4.22.ebuild
index e576da2c7f0d..4b5624846494 100644
--- a/x11-plugins/pidgin-musictracker/pidgin-musictracker-0.4.22.ebuild
+++ b/x11-plugins/pidgin-musictracker/pidgin-musictracker-0.4.22.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools
@@ -14,15 +14,18 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="debug"
-DEPEND=">=net-im/pidgin-2.0.0[gtk]
- >=dev-libs/dbus-glib-0.73
+DEPEND="
+ dev-libs/dbus-glib
dev-libs/libpcre
- >=sys-devel/gettext-0.17"
+ net-im/pidgin[gtk]"
RDEPEND="${DEPEND}"
+BDEPEND="sys-devel/gettext"
+
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
src_prepare() {
default
- sed -i -e "s/DOMAIN/PACKAGE/g" po/Makefile.in.in || die "sed failed"
+ sed -i -e "s/DOMAIN/PACKAGE/g" po/Makefile.in.in || die
eautoreconf
}
@@ -34,5 +37,5 @@ src_configure() {
src_install() {
default
- find "${D}" -name "*.la" -delete || die "error cleaning la file."
+ find "${ED}" -name '*.la' -delete || die
}
diff --git a/x11-plugins/pidgin-telegram/Manifest b/x11-plugins/pidgin-telegram/Manifest
index bc7fa2f02b41..8dd946628d6b 100644
--- a/x11-plugins/pidgin-telegram/Manifest
+++ b/x11-plugins/pidgin-telegram/Manifest
@@ -1,6 +1,3 @@
-AUX pidgin-telegram-1.4.3-clang.patch 3674 BLAKE2B c1fb52b984168afcd576b429ab97f92b44a04bdbe39af9f98c71a76bb0a18c9b82a0b7e16a5dd0c70cbd0d743a3a597b2cae9eea9ee04cb98674699452b0fea2 SHA512 f855a52582dc05266e3ac1410af668f6ce6e7f9a074d514b07c5d7c39b317f338967c41732f56db427bd3ab33b91af67d0df354ae1d43663abc45fd4edacfd02
-DIST telegram-purple_1.4.4.orig.tar.gz 495386 BLAKE2B 7ecac3a334f88f3d9c0367c5910d3de03b1e6749f18628a58f90c0ae3602dd04d0a1bec79b1016af236375bfe3eb7d4c40437c31fbbee0e9648e5425e40bb43d SHA512 9907da48b978294749f0697313cc7dbf26358535d6528190d8b61cdce5e478af8e756528a212af806025eb75b7f7ec90054ee763eea327f101ef469d0f4fd43e
DIST telegram-purple_1.4.6.orig.tar.gz 497757 BLAKE2B 1f666aaf4ef1913420cf735e3d85e1d91be8a2f07932785d55bc0be37e2cd8cabaf6b0be2b520afafc6636a692086be180d3bd4438215f8b14ae867da9891e18 SHA512 bf3e14a2d1dec7382833011ea891ba5bce81820766b3d6adee582bf0257baadeb7aa7eab7aa6e20adf8dd7728eb653db35b1d8f56bfffe7a92f9bf7506401e6e
-EBUILD pidgin-telegram-1.4.4.ebuild 1242 BLAKE2B 2981f5225498ee1b2cd78d2891e59fea80bac0bfc903f297b3e56e74f6f7bb402020089a00ec918ddce67c17b7cba40a286325f7f51afb7c6d61c3471c0d3b29 SHA512 35e07021eb2f97d931fc2805d30c9ae4911b7d6c990d7de7cdb6ca733993df9de53843049fe90e716b62d2a4bc8c71b0d356722e6ddd03205d37cdbaa2c6727a
-EBUILD pidgin-telegram-1.4.6.ebuild 1191 BLAKE2B a11bb41ddd06c91f62ab4ee173529d999606017a2da51f622b6057a9d5d61446eef95b7abdc8342da7ad9b22984aa6d036dd819668803fa883fa125090f17712 SHA512 5e89c5623800a170276af0bb519a5fb7d3fbfdf911e6309fa2d62b6520f322c63c383f3e42c75829f96a612620b666c008fc93b5ff4348c37ec25ae52128fa3e
+EBUILD pidgin-telegram-1.4.6.ebuild 1189 BLAKE2B 8ef8d8d2c49cc7d78817d99858381ff7fad19e01654075514ae6005093c4ec5077d7580b471e574da988da363aad017f203ceb8fee2c0f767e86e021046ec8dd SHA512 f5c80bb32141ccf01e71937a227f4ed1226b7955c92ed1e92dfdf37fd34f600aed71e5df1e363ff7eb6441202f42e2cb1d808b9f4a0be0a30982a7dc1d59fb50
MISC metadata.xml 722 BLAKE2B fb8498a592b6da08fda5cb1961fd84ea2a4e839233719330625166f487f2d01e8000860d2383488ea1c377105f8d74aae928871f349ed08efda1dd7c0420db10 SHA512 6b7e5121c5662de9943b7b7d30e6acf6c2df04b5c9d19b3ce942b6e403e62023f1a07076c4023d899ccb97f7fd2a29b331f9bf76391cb5db1c477d5bfce088c8
diff --git a/x11-plugins/pidgin-telegram/files/pidgin-telegram-1.4.3-clang.patch b/x11-plugins/pidgin-telegram/files/pidgin-telegram-1.4.3-clang.patch
deleted file mode 100644
index d7d00d6234e3..000000000000
--- a/x11-plugins/pidgin-telegram/files/pidgin-telegram-1.4.3-clang.patch
+++ /dev/null
@@ -1,101 +0,0 @@
-From b196e11eabb14d11e5a6b4c3cd65bf115a71f0d9 Mon Sep 17 00:00:00 2001
-From: Conrad Kostecki <conrad@kostecki.com>
-Date: Wed, 16 Sep 2020 20:55:21 +0200
-Subject: [PATCH] configure: fix compilation with clang
-
-If -L/usr/lib is being included, this will break compiling on 64-bit with clang.
-
-Signed-off-by: Conrad Kostecki <conrad@kostecki.com>
----
- configure | 11 ++++-------
- 1 file changed, 4 insertions(+), 7 deletions(-)
-
-diff --git a/configure b/configure
-index 5142055..aed9234 100755
---- a/configure
-+++ b/configure
-@@ -2283,11 +2283,10 @@ ac_config_headers="$ac_config_headers config.h"
- #
- # If both header file and library are found, shell commands
- # 'action-if-found' is run. If 'action-if-found' is not specified, the
--# default action appends '-I${ZLIB_HOME}/include' to CPFLAGS, appends
--# '-L$ZLIB_HOME}/lib' to LDFLAGS, prepends '-lz' to LIBS, and calls
--# AC_DEFINE(HAVE_LIBZ). You should use autoheader to include a definition
--# for this symbol in a config.h file. Sample usage in a C/C++ source is as
--# follows:
-+# default action appends '-I${ZLIB_HOME}/include' to CPFLAGS,prepends '-lz'
-+# to LIBS, and calls AC_DEFINE(HAVE_LIBZ). You should use autoheader to
-+# include a definition for this symbol in a config.h file.
-+# Sample usage in a C/C++ source is as follows:
- #
- # #ifdef HAVE_LIBZ
- # #include <zlib.h>
-@@ -4079,7 +4078,6 @@ then
- ZLIB_OLD_LDFLAGS=$LDFLAGS
- ZLIB_OLD_CPPFLAGS=$CPPFLAGS
- if test -n "${ZLIB_HOME}"; then
-- LDFLAGS="$LDFLAGS -L${ZLIB_HOME}/lib"
- CPPFLAGS="$CPPFLAGS -I${ZLIB_HOME}/include"
- fi
-
-@@ -4152,7 +4150,6 @@ ac_compiler_gnu=$ac_cv_c_compiler_gnu
- #
-
- CPPFLAGS="$CPPFLAGS -I${ZLIB_HOME}/include"
-- LDFLAGS="$LDFLAGS -L${ZLIB_HOME}/lib"
- LIBS="-lz $LIBS"
-
- $as_echo "#define HAVE_LIBZ 1" >>confdefs.h
---
-2.28.0
-
-From b7d92ac6c01f006dde8d317a4311497c6eda0bd7 Mon Sep 17 00:00:00 2001
-From: Conrad Kostecki <conrad@kostecki.com>
-Date: Wed, 16 Sep 2020 21:02:07 +0200
-Subject: [PATCH] configure: fix compilation with clang
-
-If -L/usr/lib is being included, this will break compiling on 64-bit with clang.
-
-Signed-off-by: Conrad Kostecki <conrad@kostecki.com>
----
- configure | 11 ++++-------
- 1 file changed, 4 insertions(+), 7 deletions(-)
-
-diff --git a/tgl/configure b/tgl/configure
-index 701a5d6..7ff1dac 100755
---- a/tgl/configure
-+++ b/tgl/configure
-@@ -2245,11 +2245,10 @@
- #
- # If both header file and library are found, shell commands
- # 'action-if-found' is run. If 'action-if-found' is not specified, the
--# default action appends '-I${ZLIB_HOME}/include' to CPFLAGS, appends
--# '-L$ZLIB_HOME}/lib' to LDFLAGS, prepends '-lz' to LIBS, and calls
--# AC_DEFINE(HAVE_LIBZ). You should use autoheader to include a definition
--# for this symbol in a config.h file. Sample usage in a C/C++ source is as
--# follows:
-+# default action appends '-I${ZLIB_HOME}/include' to CPFLAGS, prepends '-lz'
-+# to LIBS, and calls AC_DEFINE(HAVE_LIBZ). You should use autoheader to
-+# include a definition for this symbol in a config.h file. Sample usage
-+# in a C/C++ source is as follows:
- #
- # #ifdef HAVE_LIBZ
- # #include <zlib.h>
-@@ -4072,7 +4071,6 @@
- ZLIB_OLD_LDFLAGS=$LDFLAGS
- ZLIB_OLD_CPPFLAGS=$CPPFLAGS
- if test -n "${ZLIB_HOME}"; then
-- LDFLAGS="$LDFLAGS -L${ZLIB_HOME}/lib"
- CPPFLAGS="$CPPFLAGS -I${ZLIB_HOME}/include"
- fi
-
-@@ -4145,7 +4143,6 @@
- #
-
- CPPFLAGS="$CPPFLAGS -I${ZLIB_HOME}/include"
-- LDFLAGS="$LDFLAGS -L${ZLIB_HOME}/lib"
- LIBS="-lz $LIBS"
-
- $as_echo "#define HAVE_LIBZ 1" >>confdefs.h
---
-2.28.0
diff --git a/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.4.ebuild b/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.4.ebuild
deleted file mode 100644
index 3687b6477ca2..000000000000
--- a/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.4.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="A libpurple protocol plugin that adds support for the Telegram messenger"
-HOMEPAGE="https://github.com/majn/telegram-purple"
-SRC_URI="https://github.com/majn/telegram-purple/releases/download/v${PV}/telegram-purple_${PV}.orig.tar.gz"
-
-LICENSE="GPL-2+"
-KEYWORDS="amd64 x86"
-SLOT="0"
-IUSE="gcrypt libressl +nls +png +webp"
-
-RDEPEND="
- net-im/pidgin
- sys-libs/zlib:=
- gcrypt? ( dev-libs/libgcrypt:0= )
- !gcrypt? (
- libressl? ( dev-libs/libressl:0= )
- !libressl? ( dev-libs/openssl:0= )
- )
- png? ( media-libs/libpng:0= )
- webp? ( media-libs/libwebp:= )
-"
-
-DEPEND="${RDEPEND}"
-
-BDEPEND="
- nls? ( sys-devel/gettext )
- virtual/pkgconfig
-"
-
-S="${WORKDIR}/telegram-purple"
-
-DOCS=( "AUTHORS" "CHANGELOG.md" "HACKING.md" "HACKING.BUILD.md" "README.md" )
-
-PATCHES=( "${FILESDIR}/${PN}-1.4.3-clang.patch" )
-
-src_prepare() {
- default
-
- # Remove '-Werror' to make it compile
- find -name 'Makefile*' -exec sed -i -e 's/-Werror //' {} + || die
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_enable gcrypt)
- $(use_enable nls translation)
- $(use_enable png libpng)
- $(use_enable webp libwebp)
- )
-
- econf "${myeconfargs[@]}"
-}
diff --git a/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.6.ebuild b/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.6.ebuild
index 06014ab6c69c..ce82b54c47d4 100644
--- a/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.6.ebuild
+++ b/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.6.ebuild
@@ -9,7 +9,7 @@ SRC_URI="https://github.com/majn/telegram-purple/releases/download/v${PV}/telegr
S="${WORKDIR}/telegram-purple"
LICENSE="GPL-2+"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
SLOT="0"
IUSE="gcrypt libressl +nls +png +webp"
diff --git a/x11-plugins/vicious/Manifest b/x11-plugins/vicious/Manifest
index 318ba09a97cf..8a20316216fc 100644
--- a/x11-plugins/vicious/Manifest
+++ b/x11-plugins/vicious/Manifest
@@ -1,5 +1,5 @@
DIST vicious-2.3.1.tar.gz 47484 BLAKE2B 2ef6e51507faf7477800091c738e65184439caba9b79004b53f3a479f1370ca64046bc1664c6b746d8ab71370b36f29095406439e2a8fab7524e6bb190350fb7 SHA512 9e89d36d708a7ccdff206451dfb98db8455a16f9d2254167a446af91fadc2103a5274442f38ddf1eb919da23480b6790639cdbbde4a08bffc1cf9221622064c9
DIST vicious-2.5.0.tar.gz 67557 BLAKE2B ffbc1b3c0e32b554cc367a51e5e17130e1b9f7fed2e8505aaa1845719ecd6d465d43ba839ac3a9b73a87e43ff3144c2074f3750d5f67b516d033a74144e9e12f SHA512 deb21587d1d7f2e6e4dd77c74abbfa337acf6c99ef9bebc0e505f1508afc6e3b03f043a639f866fcda0191447c103d3fba51376682201482fb669a263321dee5
EBUILD vicious-2.3.1.ebuild 670 BLAKE2B a96e57a97480303b302d1c387de5f9ee8d86173af0c1ccbc3b100a8292a6bbe0b0e679f930eb881b66d655640bf10b3d95052e468181d1baf31e68cda6a3ae4c SHA512 0a1ae727bca18f54e06a4df1cea575328a10604dc85046e1f1ec242eeb22e4d57544ecc2bc6c349b538b1cead65840f75a2797aa41ee70595a33f5c3810d13d0
-EBUILD vicious-2.5.0.ebuild 2267 BLAKE2B d1bc5ce6e86510954ccf86fea58e75e15e9f59f3ecf414f902fe1b9cf40de084b32a2fb56b7bdd13f62a8485b30d37a629b2d8382bd699c1cbe1fc24c2f7722a SHA512 5b7e40b7fbfe4e58b60c26bdee583783b36dfc349f65c460c7ceda87b037367faa6fc9262e7bb05918987bd7c0ebb34d82beecea7365659b1a938feea5a1ec37
+EBUILD vicious-2.5.0.ebuild 2277 BLAKE2B ddca499dd47301b994fa3401edf4c716c93d944f55b2f790786720283c5e696994f273486a2e23a6c26a70ba002caa63dc2dbd687531e27c765aa3f0132209c9 SHA512 214537595afaf917dbdd0ef9e928cc52abf985fc31b6c210696c6aabfa8abda0cec3b7cbb682b65f1ee35ba6226063d1455fba8f7681d87f58e94d8d3a3ee00d
MISC metadata.xml 467 BLAKE2B e2275dacd87f47bbca44c35c04695410193e190a0c478d359f2834d4f1a07e24f887dfddd91efc844a453ec15286e638efda98a31eca6e0539861d3f2cd6b39c SHA512 20b743701dabb4a037d6720a4d6ebc29d1abecffc60cf191b6b799c87192dbdac3e11b68d5cfb3b9b6f1a275e50bd1ce8d2d6eb1a157f6b68f83416652ce2122
diff --git a/x11-plugins/vicious/vicious-2.5.0.ebuild b/x11-plugins/vicious/vicious-2.5.0.ebuild
index 32f7e2f8ca29..77a4b1bedcce 100644
--- a/x11-plugins/vicious/vicious-2.5.0.ebuild
+++ b/x11-plugins/vicious/vicious-2.5.0.ebuild
@@ -18,7 +18,7 @@ RDEPEND="x11-wm/awesome"
src_install() {
insinto /usr/share/awesome/lib/vicious
- doins -r widgets helpers.lua init.lua
+ doins -r widgets spawn.lua helpers.lua init.lua
if use contrib; then
insinto /usr/share/awesome/lib/vicious/contrib