summaryrefslogtreecommitdiff
path: root/x11-terms/kitty-terminfo
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/kitty-terminfo')
-rw-r--r--x11-terms/kitty-terminfo/Manifest7
-rw-r--r--x11-terms/kitty-terminfo/files/kitty-terminfo-setup-0.17.2.patch44
-rw-r--r--x11-terms/kitty-terminfo/files/kitty-terminfo-setup.patch44
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-0.16.0.ebuild45
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-0.17.2.ebuild41
-rw-r--r--x11-terms/kitty-terminfo/metadata.xml15
6 files changed, 196 insertions, 0 deletions
diff --git a/x11-terms/kitty-terminfo/Manifest b/x11-terms/kitty-terminfo/Manifest
new file mode 100644
index 000000000000..9f1c65d6efac
--- /dev/null
+++ b/x11-terms/kitty-terminfo/Manifest
@@ -0,0 +1,7 @@
+AUX kitty-terminfo-setup-0.17.2.patch 1707 BLAKE2B 6670b86ac9ed5063d2d2bd855ecd274bc14953e0ad836d9a858d425fec4811a92590a551e56a861780d01bcc9152bdaaf0f7d57e5af92b640e14cf97b72feb76 SHA512 982860794a23aa7c97de0c45a462b16ad1f0d596b0f178a10ee304f4926bb8378639b2de4842c7f2a43a4a90a652e6934a8f6891f008547824efd273113d284f
+AUX kitty-terminfo-setup.patch 1700 BLAKE2B e911716feedacd9463667a020e69afa0de8b982f78f3673eb690827ec20baf244cafca903b468577dfb6d6f11df0ac4a6fb0d6ff60b041d2bb4ec9c4c36b051c SHA512 632ca4639df03ecd923e0c650c543ac9f1a74527742fd7bfe0d2ca923ca45cfb6315664f5ed1e7cb72034c1c820cfb4757edc92843750169356fa0364a0bceca
+DIST kitty-0.16.0.tar.xz 2974592 BLAKE2B 971e279cd24369a454495fc7a236356e6a4ee69a0953563a9283a16e21bd67ddea5ab8f795c75be6cd31d05c5f1b39b1525e957b9bcd59d12ea3e701b21aa59c SHA512 24dedfc58c5d33aa18da85f904952129f39cd54afb70282c7572b57514b1deebfb532414913e0efc3a5c0352a81406cd7ddef99490dbd9186dc61eab7af3975b
+DIST kitty-0.17.2.tar.xz 3044140 BLAKE2B 12dcb8ddb7d90a22904f575301e8c2b1672c3212ee29a035fa5e8eec553dafb0e2c8c1cc3a491c8ac6854d619e979e518d83c5218f36647a032a4f847d068ef3 SHA512 bccf1c1d60d1149bc5f849b82db1af80a2d9a7a11c5f2df853daae5700550eef98da389a30f015d67be796f39deacb31f3ee245eb37ba1a41ba377c70cd26d61
+EBUILD kitty-terminfo-0.16.0.ebuild 1054 BLAKE2B ba4622acecf495cd0d6ba92449b09c39e3f0518a1954932569d609719b9c2c562534ed3e2fcc620486020d1be42aa6f6b0e71b38374c9eb2b8eb17a2e8686931 SHA512 5f06a74271da119899325f2335a11252d0ccca6b34078150d707d7dbac7f789988c772d5aa78554a3f5ff05b5165c1bd6685929b7b44919b06a806c7c8141c44
+EBUILD kitty-terminfo-0.17.2.ebuild 997 BLAKE2B 2b0cb0ab2cae14ec8ffab109ee3e429f258b4e3e05c1d6ceed4deec1dcce47923151961ecba4f3c9caa4ea8d75beff9b3791de728c9cc40b34465382f5ae6aa2 SHA512 1a3389f67d6b19fee38385b5bafcf48be9e839761f883581fef433528d1cda5a86b48fc03a244572c0f33f0ef66d1f3d6ddc55140915adb19e5fdfee9c3f90bf
+MISC metadata.xml 464 BLAKE2B 5b6a988d0c9a9eb68e9e269b3f423915d4471b535dfb466fec8b9856ecbfb8d1d51decf34576f8522852bf59f1264e4a1d3b777363de221d0d114edcb9628cfa SHA512 90d9e9db675bd68fab9865526234692c3fb34086822b2b2c47eaec4d9a4f8ef10be41d8c9bf3801e579f8bcf541528dd09ea042f54f6f27319ea82bc4288745d
diff --git a/x11-terms/kitty-terminfo/files/kitty-terminfo-setup-0.17.2.patch b/x11-terms/kitty-terminfo/files/kitty-terminfo-setup-0.17.2.patch
new file mode 100644
index 000000000000..31aa669e0a5e
--- /dev/null
+++ b/x11-terms/kitty-terminfo/files/kitty-terminfo-setup-0.17.2.patch
@@ -0,0 +1,44 @@
+--- a/setup.py 2020-03-12 00:28:46.725956882 +0100
++++ b/setup.py 2020-03-12 00:38:55.557945979 +0100
+@@ -876,6 +876,14 @@
+ create_macos_bundle_gunk(ddir)
+ # }}}
+
++def terminfo(args):
++ ddir = args.prefix
++ libdir = os.path.join(ddir, args.libdir_name.strip('/'), 'kitty')
++ build_terminfo = runpy.run_path('build-terminfo', run_name='import_build')
++ for x in (libdir, os.path.join(ddir, 'share')):
++ odir = os.path.join(x, 'terminfo')
++ safe_makedirs(odir)
++ build_terminfo['compile_terminfo'](odir)
+
+ def clean():
+
+@@ -889,7 +897,7 @@
+
+ safe_remove(
+ 'build', 'compile_commands.json', 'link_commands.json',
+- 'linux-package', 'kitty.app', 'asan-launcher',
++ 'linux-package', 'linux-terminfo', 'kitty.app', 'asan-launcher',
+ 'kitty-profile', 'kitty/launcher')
+ exclude = ('.git',)
+ for root, dirs, files in os.walk('.', topdown=True):
+@@ -910,7 +918,7 @@
+ 'action',
+ nargs='?',
+ default=Options.action,
+- choices='build test linux-package kitty.app linux-freeze macos-freeze clean'.split(),
++ choices='build test linux-package linux-terminfo kitty.app linux-freeze macos-freeze clean'.split(),
+ help='Action to perform (default is build)'
+ )
+ p.add_argument(
+@@ -1007,6 +1015,8 @@
+ elif args.action == 'linux-package':
+ build(args, native_optimizations=False)
+ package(args, bundle_type='linux-package')
++ elif args.action == 'linux-terminfo':
++ terminfo(args)
+ elif args.action == 'linux-freeze':
+ build(args, native_optimizations=False)
+ package(args, bundle_type='linux-freeze')
diff --git a/x11-terms/kitty-terminfo/files/kitty-terminfo-setup.patch b/x11-terms/kitty-terminfo/files/kitty-terminfo-setup.patch
new file mode 100644
index 000000000000..5ff1fa2d77d9
--- /dev/null
+++ b/x11-terms/kitty-terminfo/files/kitty-terminfo-setup.patch
@@ -0,0 +1,44 @@
+--- a/setup.py 2020-03-12 00:28:46.725956882 +0100
++++ b/setup.py 2020-03-12 00:38:55.557945979 +0100
+@@ -876,6 +876,14 @@
+ create_macos_bundle_gunk(ddir)
+ # }}}
+
++def terminfo(args):
++ ddir = args.prefix
++ libdir = os.path.join(ddir, args.libdir_name.strip('/'), 'kitty')
++ build_terminfo = runpy.run_path('build-terminfo', run_name='import_build')
++ for x in (libdir, os.path.join(ddir, 'share')):
++ odir = os.path.join(x, 'terminfo')
++ safe_makedirs(odir)
++ build_terminfo['compile_terminfo'](odir)
+
+ def clean():
+
+@@ -889,7 +897,7 @@
+
+ safe_remove(
+ 'build', 'compile_commands.json', 'link_commands.json',
+- 'linux-package', 'kitty.app', 'asan-launcher',
++ 'linux-package', 'linux-terminfo', 'kitty.app', 'asan-launcher',
+ 'kitty-profile', 'kitty/launcher')
+ exclude = ('.git',)
+ for root, dirs, files in os.walk('.', topdown=True):
+@@ -910,7 +918,7 @@
+ 'action',
+ nargs='?',
+ default='build',
+- choices='build test linux-package kitty.app linux-freeze macos-freeze clean'.split(),
++ choices='build test linux-package linux-terminfo kitty.app linux-freeze macos-freeze clean'.split(),
+ help='Action to perform (default is build)'
+ )
+ p.add_argument(
+@@ -1007,6 +1015,8 @@
+ elif args.action == 'linux-package':
+ build(args, native_optimizations=False)
+ package(args, bundle_type='linux-package')
++ elif args.action == 'linux-terminfo':
++ terminfo(args)
+ elif args.action == 'linux-freeze':
+ build(args, native_optimizations=False)
+ package(args, bundle_type='linux-freeze')
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-0.16.0.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-0.16.0.ebuild
new file mode 100644
index 000000000000..6ceb2f1ead77
--- /dev/null
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-0.16.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-single-r1 toolchain-funcs xdg
+
+DESCRIPTION="Terminfo for kitty, an OpenGL-based terminal emulator"
+HOMEPAGE="https://github.com/kovidgoyal/kitty"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/kitty-terminfo-setup.patch
+)
+
+# kitty-terminfo is a split package from kitty that only installs the terminfo
+# file. As tests are designed to be run with the whole package compiled they
+# would fail in this case.
+RESTRICT="test"
+
+src_compile() {
+ "${EPYTHON}" setup.py \
+ --verbose $(usex debug --debug "") \
+ --libdir-name $(get_libdir) \
+ linux-terminfo || die "Failed to compile kitty."
+}
+
+src_install() {
+ insinto /usr
+ doins -r linux-package/*
+}
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-0.17.2.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-0.17.2.ebuild
new file mode 100644
index 000000000000..b37c1bba5c12
--- /dev/null
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-0.17.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-any-r1 toolchain-funcs xdg
+
+DESCRIPTION="Terminfo for kitty, an OpenGL-based terminal emulator"
+HOMEPAGE="https://github.com/kovidgoyal/kitty"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="${PYTHON_DEPS}"
+
+PATCHES=(
+ "${FILESDIR}"/kitty-terminfo-setup-0.17.2.patch
+)
+
+# kitty-terminfo is a split package from kitty that only installs the terminfo
+# file. As tests are designed to be run with the whole package compiled they
+# would fail in this case.
+RESTRICT="test"
+
+src_compile() {
+ "${EPYTHON}" setup.py \
+ --verbose $(usex debug --debug "") \
+ --libdir-name $(get_libdir) \
+ linux-terminfo || die "Failed to compile kitty."
+}
+
+src_install() {
+ insinto /usr
+ doins -r linux-package/*
+}
diff --git a/x11-terms/kitty-terminfo/metadata.xml b/x11-terms/kitty-terminfo/metadata.xml
new file mode 100644
index 000000000000..2c9e05543121
--- /dev/null
+++ b/x11-terms/kitty-terminfo/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>pabloorduna98@gmail.com</email>
+ <name>Pablo Orduna</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Gentoo Proxy Maintainers Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">kovidgoyal/kitty</remote-id>
+ </upstream>
+</pkgmetadata>