summaryrefslogtreecommitdiff
path: root/x11-terms/terminology/terminology-1.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/terminology/terminology-1.0.0.ebuild')
-rw-r--r--x11-terms/terminology/terminology-1.0.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/x11-terms/terminology/terminology-1.0.0.ebuild b/x11-terms/terminology/terminology-1.0.0.ebuild
new file mode 100644
index 000000000000..dc28f45542c1
--- /dev/null
+++ b/x11-terms/terminology/terminology-1.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+MY_P=${P/_/-}
+
+if [[ "${PV}" == "9999" ]] ; then
+ EGIT_SUB_PROJECT="apps"
+ EGIT_URI_APPEND="${PN}"
+else
+ SRC_URI="https://download.enlightenment.org/rel/apps/${PN}/${MY_P}.tar.xz"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+fi
+
+inherit enlightenment
+
+DESCRIPTION="Feature rich terminal emulator using the Enlightenment Foundation Libraries"
+HOMEPAGE="https://www.enlightenment.org/p.php?p=about/terminology"
+
+RDEPEND=">=dev-libs/efl-1.18"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"