summaryrefslogtreecommitdiff
path: root/x11-themes/chameleon-xcursors/chameleon-xcursors-0.5-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/chameleon-xcursors/chameleon-xcursors-0.5-r2.ebuild')
-rw-r--r--x11-themes/chameleon-xcursors/chameleon-xcursors-0.5-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-themes/chameleon-xcursors/chameleon-xcursors-0.5-r2.ebuild b/x11-themes/chameleon-xcursors/chameleon-xcursors-0.5-r2.ebuild
new file mode 100644
index 000000000000..435e7cda0663
--- /dev/null
+++ b/x11-themes/chameleon-xcursors/chameleon-xcursors-0.5-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg
+
+COLOURS=( "Anthracite" "DarkSkyBlue" "SkyBlue" "Pearl" "White" )
+MY_PN="Chameleon"
+
+DESCRIPTION="Style neutral scalable cursor theme"
+HOMEPAGE="https://store.kde.org/p/999948/"
+for COLOUR in "${COLOURS[@]}"; do
+ SRC_URI="${SRC_URI} mirror://gentoo/${MY_PN}-${COLOUR}-${PV}.tar.bz2"
+done
+S="${WORKDIR}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="x11-libs/libXcursor"
+
+src_install() {
+ dodir /usr/share/cursors/xorg-x11/
+
+ for COLOUR in "${COLOURS[@]}"; do
+ for SIZE in Large Regular Small; do
+ local name="${MY_PN}-${COLOUR}-${SIZE}"
+ rm "${WORKDIR}"/${name}-${PV}/{COPYRIGHT,LICENSE} || die
+ insinto /usr/share/cursors/xorg-x11/${name}
+ doins -r "${WORKDIR}"/${name}-${PV}
+ done
+ done
+}