summaryrefslogtreecommitdiff
path: root/x11-wm/larswm/larswm-7.5.3-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/larswm/larswm-7.5.3-r2.ebuild')
-rw-r--r--x11-wm/larswm/larswm-7.5.3-r2.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/x11-wm/larswm/larswm-7.5.3-r2.ebuild b/x11-wm/larswm/larswm-7.5.3-r2.ebuild
index 6506e3b2921d..8adcdfe73021 100644
--- a/x11-wm/larswm/larswm-7.5.3-r2.ebuild
+++ b/x11-wm/larswm/larswm-7.5.3-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,16 +17,16 @@ RDEPEND="x11-libs/libX11
x11-libs/libXmu
x11-libs/libXt
x11-libs/libXext"
-DEPEND="${RDEPEND}"
-BDEPEND="
- x11-base/xorg-proto
- >=x11-misc/imake-1.0.8-r1
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="app-text/rman
+ sys-devel/gcc
x11-misc/gccmakedep
- app-text/rman"
+ >=x11-misc/imake-1.0.8-r1"
src_configure() {
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
- IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf -a || die
+ IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf -a || die
}
src_compile() {