summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/Manifest.gzbin9789 -> 9793 bytes
-rw-r--r--x11-wm/herbstluftwm/Manifest2
-rw-r--r--x11-wm/herbstluftwm/herbstluftwm-0.9.5.ebuild141
3 files changed, 143 insertions, 0 deletions
diff --git a/x11-wm/Manifest.gz b/x11-wm/Manifest.gz
index ab0e36132532..ee00587f1f6a 100644
--- a/x11-wm/Manifest.gz
+++ b/x11-wm/Manifest.gz
Binary files differ
diff --git a/x11-wm/herbstluftwm/Manifest b/x11-wm/herbstluftwm/Manifest
index bafab0d62a2f..343b7623d5ee 100644
--- a/x11-wm/herbstluftwm/Manifest
+++ b/x11-wm/herbstluftwm/Manifest
@@ -1,4 +1,6 @@
DIST herbstluftwm-0.9.4.tar.gz 549029 BLAKE2B 23f1dbf212c4d0a64f2e2d8442ac7c2465a54a13af74de6c949c4d6eda85fd4e66b73188c526d0968372eb45691ffca43e387c8410691fd134f662e1e8c501b3 SHA512 068438d14b0addcd17a0c0bda1d33ec4aaff08a3c85698a49e9d3dd0c07f91e315f936d73c11b0c159b8735373ea1efe8a572a0976fc327f4aaa6a0f08436e9d
+DIST herbstluftwm-0.9.5.tar.gz 556773 BLAKE2B db851f02ce249be74f0104dd0b335fb1ed50b4a19e5f7de17cdc34b7eba99ac2f348c5a4a4e0afd2c68576f650029203c735ccb293a60d321769d56f746d6593 SHA512 a85fd1ab16b873f512d6965cc4a93524e3ed4a15079d0d4ee54012e217bd41db3b54729c1b30ee361c34b38799f95bc537099056ba7a5f791bf2be6724bc92c3
EBUILD herbstluftwm-0.9.4.ebuild 2986 BLAKE2B a2eb901d21217a3960324ddd2eccfcd8e26254ca9e88ac6de266e6e97629ec2cc9f53018d0683620044d348eb348bed2cc5f0f0a4329e815f00fad8dbadab991 SHA512 b7c7900c1f84c4a2e75c61a009d8d504a5f0009b3d1b61ac3a58fd0562b3661468d266975e2fb201143dd9ba6258e11dd51af376b288598a4abfece06a2a8a79
+EBUILD herbstluftwm-0.9.5.ebuild 2988 BLAKE2B 2ecb6e7cfbf2edecc2b59c3549fad303f789ed9aad902a516359b9b3aae98bda69da512d9a54a9ef6d7d4deab5f00b3f3e6b96282b41ae45256f1ae4c5ca4076 SHA512 ec915b61d54cbf11451cfcad2da47ab753229dfa7c9a52e3eeb490fbe67cc16a4cd02158c740b55563ad0587582ffae21baf73cc0b0fe75df4d5f4fee01eebd2
EBUILD herbstluftwm-9999.ebuild 3400 BLAKE2B ebc8f10a0506aa602092455f0e51b8c1ca3c2a3d4a6c585a6210ffe240b1006b0dcebff3282b8c84eef02605679c86ccfb8900aa4f2c2486a7ca95d0dd39c446 SHA512 0b1be1854a4a331ded3929d4cbb9045a8a690b9da1d916c6cd1a67d12eac9f53c4bc6ae74bbd756d6193f11ad50127362445e2cba1d79dab375ccd7cc0e5456d
MISC metadata.xml 337 BLAKE2B 7ef28bc6ce30abb6c2f44524b4dd05a479cd5ca2b98901ffe570b870d0b98f94589cd1d3f197ee7e3fd90f4c73144e1dc44996df8b1b3ec28ce6950578ada74e SHA512 6e7cb80e1870901554ac0c2a4947cceb4e6284ccc84714bb0f42dbfa69cab5b32a8bd34fd384731b9462535d7e80feef606030be3e03babc80828a980050f333
diff --git a/x11-wm/herbstluftwm/herbstluftwm-0.9.5.ebuild b/x11-wm/herbstluftwm/herbstluftwm-0.9.5.ebuild
new file mode 100644
index 000000000000..4989b68eb8db
--- /dev/null
+++ b/x11-wm/herbstluftwm/herbstluftwm-0.9.5.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_OPTIONAL=1
+
+inherit cmake distutils-r1
+
+DESCRIPTION="A manual tiling window manager for X"
+HOMEPAGE="https://herbstluftwm.org/"
+
+if [[ "${PV}" == "9999" ]] || [[ -n "${EGIT_COMMIT_ID}" ]]; then
+ EGIT_REPO_URI="https://github.com/herbstluftwm/herbstluftwm"
+ inherit git-r3
+else
+ SRC_URI="https://herbstluftwm.org/tarballs/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="+doc python test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+COMMON_DEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXrender
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ test? (
+ dev-python/ewmh
+ dev-python/python-xlib
+ x11-apps/xsetroot
+ x11-base/xorg-server[xephyr,xvfb]
+ x11-misc/xdotool
+ x11-terms/xterm
+ )
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ app-shells/bash
+ python? ( ${PYTHON_DEPS} )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+if [[ -n "${EGIT_REPO_URI}" ]]; then
+ # Herbstluftwm tarballs ship with pre-compiled documentation, only
+ # if we build from git asciidoc is needed.
+ BDEPEND+=" doc? ( app-text/asciidoc )"
+fi
+
+src_prepare() {
+ # Do not install LICENSE and respect CMAKE_INSTALL_DOCDIR.
+ sed -i \
+ -e '/^install.*LICENSEDIR/d' \
+ -e '/set(DOCDIR / s#.*#set(DOCDIR ${CMAKE_INSTALL_DOCDIR})#' \
+ CMakeLists.txt || die
+ cmake_src_prepare
+
+ if use python; then
+ pushd "${S}"/python > /dev/null || die
+ distutils-r1_src_prepare
+ popd > /dev/null || die
+ fi
+}
+
+src_configure() {
+ # Ensure that 'python3' is in PATH. #765118
+ python_setup
+
+ mycmakeargs=(
+ -DWITH_DOCUMENTATION=$(usex doc)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ if use python; then
+ pushd python > /dev/null || die
+ distutils-r1_src_compile
+ popd >/dev/null || die
+ fi
+}
+
+src_install() {
+ cmake_src_install
+
+ if ! use doc; then
+ rm -r "${ED}"/usr/share/doc/${PF}/examples || die
+ fi
+
+ if use python; then
+ pushd python > /dev/null || die
+ distutils-r1_src_install
+ popd > /dev/null || die
+ fi
+
+ # The man pages exists in src_install either in non-live ebuilds,
+ # since they are then shipped pre-compiled in herbstluftwm's
+ # release tarbal. Or they exist in live ebuilds if the 'doc' USE
+ # flag is enabled.
+ if [[ "${PV}" != 9999 ]] || use doc; then
+ local man_pages=(
+ herbstluftwm.1
+ herbstclient.1
+ herbstluftwm-tutorial.7
+ )
+ for man_page in "${man_pages[@]}"; do
+ doman "doc/${man_page}"
+ done
+ fi
+}
+
+distutils_enable_tests pytest
+
+src_test() {
+ ln -s "${BUILD_DIR}/herbstclient" || die "Could not symlink herbstclient"
+ ln -s "${BUILD_DIR}/herbstluftwm" || die "Could not symlink herbstluftwm"
+
+ pushd python > /dev/null || die
+ distutils_install_for_testing
+ popd > /dev/null || die
+
+ # Ensure PYTHONPATH is exported, see https://bugs.gentoo.org/801658.
+ export PYTHONPATH
+ python_test
+}