summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.7.ebuild')
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.7.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.7.ebuild b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.7.ebuild
new file mode 100644
index 000000000000..84165a821e17
--- /dev/null
+++ b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A system load plug-in for the Xfce panel"
+HOMEPAGE="
+ https://goodies.xfce.org/projects/panel-plugins/xfce4-cpugraph-plugin
+ https://gitlab.xfce.org/panel-plugins/xfce4-cpugraph-plugin
+"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.16.0:=
+ >=xfce-base/libxfce4util-4.17.2:=
+ >=xfce-base/xfce4-panel-4.16.0:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}