summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-cpugraph-plugin
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-cpugraph-plugin')
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.11.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-cpugraph-plugin/Manifest b/xfce-extra/xfce4-cpugraph-plugin/Manifest
index 90bc635575c9..606eed62b19f 100644
--- a/xfce-extra/xfce4-cpugraph-plugin/Manifest
+++ b/xfce-extra/xfce4-cpugraph-plugin/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-cpugraph-plugin-1.2.10.tar.bz2 440958 BLAKE2B a64ced65c93edf86329ab72fc538960ad529cc090c323eaff2d0eb1ce0edce56d7aff56d58e450666c04f975a61880cbcfc5cf627817f7aa2b835de02c6a2f46 SHA512 414c2a5da9576d2ed1f5478a07ff5c51c45eaa0a8432a31b6fb2408b81f5ab4485e3b10486af26cf33a18d23e2dc3afe21bf88630e4db91adcfa3e0f80468cf3
+DIST xfce4-cpugraph-plugin-1.2.11.tar.bz2 569026 BLAKE2B 0845eade5d84f233d6220167caad13bec0a120a817bd223469518fb42d0815d5d7a0e898ae6d9002d3b51c40792dcb27f095fc411f8d29ebf11094a56b4e2d0a SHA512 c9c9b32028c223146b5ae73df3dfff14fff38d15695459f96d9428d4b2e82d08e46eee6d2f83a2b261845b1a03df20287d7bb83a8323f48813ccb56299009d93
EBUILD xfce4-cpugraph-plugin-1.2.10.ebuild 974 BLAKE2B 62c6e24df141ade192ad51276d146c49708a36599ebee566171d676fb127b5cca2c4cd939d315c3cd8212640883599603f8c4a8f89c12dec4a563c054b4a815e SHA512 451fe575282b188805a646a6a445acc4b0d3563903e50c7d8d29801c9b3900d4cb994c65ebcd2dc9ef407fadf47210f0966733ef15d8d382a45efcf221e1c532
+EBUILD xfce4-cpugraph-plugin-1.2.11.ebuild 962 BLAKE2B cb521978e0775780174c61956cb6d7d9eb897d5488aa0f86310f984be4e9e14318a2cd09f78e030b145cfa95171d778c0967a13501ad0811001524a4fe9e5a48 SHA512 97d136007239be4e56598c517705c485e16e54d25c23cefe3e8308a0fc573da5410100c8beedfa2412bc7f37efda228248e5bb346ce770c977634fa0b261b33f
MISC metadata.xml 248 BLAKE2B 83bf47dc3dbedea8a88932e922075f0ba8fd841433c4ab750e2ab61c22e8cbfaa1acb04a903d89ef5140a75dfc4c4899354623e0160df5b7c178c190f8494515 SHA512 b5200cfe30adef8e869fada87f1b4171210b2427cd3ac12edef70948f305d5e612ca5f24d377f9823a6022c8867db635db50ddd3d6cb362d6b0137c299fe07e5
diff --git a/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.11.ebuild b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.11.ebuild
new file mode 100644
index 000000000000..f4c0389ab0dc
--- /dev/null
+++ b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.11.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A system load plug-in for the Xfce panel"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-cpugraph-plugin
+ https://gitlab.xfce.org/panel-plugins/xfce4-cpugraph-plugin/
+"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0
+ >=x11-libs/gtk+-3.22.0:3
+ >=xfce-base/libxfce4ui-4.16.0:=
+ >=xfce-base/libxfce4util-4.17.2:=
+ >=xfce-base/xfce4-panel-4.16.0:=
+ >=xfce-base/xfconf-4.12.0:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}