summaryrefslogtreecommitdiff
path: root/app-portage/sisyphus-qt/sisyphus-qt-4.2103.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-08 17:10:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-08 17:10:27 +0100
commit4a772009ccfbc4a9a465a8060950e95eda6f8e90 (patch)
tree4a208ea4641cb4f29aed0260bde6a9bcdb79137d /app-portage/sisyphus-qt/sisyphus-qt-4.2103.0-r2.ebuild
parent1593a6084bfd08b951c60bd9f5ee56aef1e504a8 (diff)
app-portage/sisyphus-{,qt} : revision bump
Diffstat (limited to 'app-portage/sisyphus-qt/sisyphus-qt-4.2103.0-r2.ebuild')
-rw-r--r--app-portage/sisyphus-qt/sisyphus-qt-4.2103.0-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-portage/sisyphus-qt/sisyphus-qt-4.2103.0-r2.ebuild b/app-portage/sisyphus-qt/sisyphus-qt-4.2103.0-r2.ebuild
new file mode 100644
index 00000000..fe371835
--- /dev/null
+++ b/app-portage/sisyphus-qt/sisyphus-qt-4.2103.0-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2016-2020 Redcore Linux Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/-qt/}"
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit eutils python-single-r1 git-r3
+
+DESCRIPTION="A simple portage python wrapper which works like other package managers(apt-get/yum/dnf)"
+HOMEPAGE="http://redcorelinux.org"
+
+EGIT_REPO_URI="https://gitlab.com/redcore/sisyphus.git"
+EGIT_BRANCH="master"
+EGIT_COMMIT="5ef298d50edc3c2d7f90150afd3a711a8c3cae68"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-lang/python[sqlite]
+ ~app-portage/sisyphus-${PV}"
+RDEPEND="${DEPEND}
+ app-misc/tmux
+ $(python_gen_cond_dep '
+ dev-python/PyQt5[designer,gui,widgets,${PYTHON_MULTI_USEDEP}]
+ ')"
+
+src_install() {
+ emake DESTDIR="${D}" install-gui
+
+ # enforce the best available python implementation (CLI)
+ python_setup
+ python_fix_shebang "${ED}"usr/share/"${MY_PN}"/"${MY_PN}"-gui.py
+}