summaryrefslogtreecommitdiff
path: root/app-portage/sisyphus-qt/sisyphus-qt-6.2305.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-03 17:56:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-03 17:56:30 +0100
commit287af34d96b36075fd35c815a1e86f86aec0baf4 (patch)
tree459f99e2943d68df4e0cb404a45e1c00bda7ac87 /app-portage/sisyphus-qt/sisyphus-qt-6.2305.0.ebuild
parent6c2098f19dd18e74ea5ccfac68b179af1199486b (diff)
app-portage/sisyphus{,-qt} : drop eutils ECLASS
Diffstat (limited to 'app-portage/sisyphus-qt/sisyphus-qt-6.2305.0.ebuild')
-rw-r--r--app-portage/sisyphus-qt/sisyphus-qt-6.2305.0.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/app-portage/sisyphus-qt/sisyphus-qt-6.2305.0.ebuild b/app-portage/sisyphus-qt/sisyphus-qt-6.2305.0.ebuild
deleted file mode 100644
index c04351d3..00000000
--- a/app-portage/sisyphus-qt/sisyphus-qt-6.2305.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 2016-2020 Redcore Linux Project
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_PN="${PN/-qt/}"
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit eutils python-single-r1 git-r3
-
-DESCRIPTION="A simple portage python wrapper which works like other package managers(apt-get/yum/dnf)"
-HOMEPAGE="http://redcorelinux.org"
-
-EGIT_REPO_URI="https://gitlab.com/redcore/sisyphus.git"
-EGIT_BRANCH="master"
-EGIT_COMMIT="78eca7889aebbc3e7f141f23a41eb9b3b79f3a69"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm64"
-IUSE=""
-
-DEPEND="dev-lang/python[sqlite]
- ~app-portage/sisyphus-${PV}"
-RDEPEND="${DEPEND}
- app-misc/tmux
- $(python_gen_cond_dep '
- dev-python/PyQt5[designer,gui,widgets,${PYTHON_USEDEP}]
- ')"
-
-src_install() {
- emake DESTDIR="${D}"/ install-gui
-
- # enforce the best available python implementation (CLI)
- python_setup
- python_fix_shebang "${ED}"/usr/share/"${MY_PN}"/"${MY_PN}"-gui.py
-}