summaryrefslogtreecommitdiff
path: root/app-portage
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-06-26 11:44:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-06-26 11:44:28 +0100
commitce4305feb442e27c9d868db7c46cc574fa0da1a5 (patch)
tree6413a374e88a045367ac874a6176076e8efa5a6f /app-portage
parent090f79994eadf4ae79ce9f42f9adbde394230059 (diff)
app-portage/sisyphus : python based code ebuild
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/sisyphus/sisyphus-0.1.ebuild42
-rw-r--r--app-portage/sisyphus/sisyphus-99999.ebuild43
2 files changed, 42 insertions, 43 deletions
diff --git a/app-portage/sisyphus/sisyphus-0.1.ebuild b/app-portage/sisyphus/sisyphus-0.1.ebuild
new file mode 100644
index 00000000..1ca621fa
--- /dev/null
+++ b/app-portage/sisyphus/sisyphus-0.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_4 )
+
+inherit eutils git-r3 python-r1
+
+DESCRIPTION="A simple portage python wrapper which works like other package managers(apt-get/yum/dnf)"
+HOMEPAGE="http://redcorelinux.org"
+
+EGIT_BRANCH=master
+EGIT_REPO_URI="https://gitlab.com/redcore/sisyphus.git"
+EGIT_COMMIT="2e307055686dcfa2c3ffe12e59bfe4e669e3c915"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-lang/python:3.4"
+RDEPEND="${DEPEND}
+ app-portage/gentoolkit[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ sys-apps/portage[${PYTHON_USEDEP}]"
+
+src_install() {
+ default
+ dosym /usr/bin/${PN}-cli.py /usr/bin/${PN}
+ dodir /var/lib/${PN}/{csv,db}
+ # don't include any graphical interface code...for now
+ rm -rf ${ED}usr/bin/${PN}-gui
+ rm -rf ${ED}usr/bin/${PN}-gui-pkexec
+ rm -rf ${ED}usr/share/${PN}/*py
+ rm -rf ${ED}usr/share/${PN}/icon
+ rm -rf ${ED}usr/share/${PN}/ui
+ rm -rf ${ED}usr/share/applications
+ rm -rf ${ED}usr/share/pixmaps
+ rm -rf ${ED}usr/share/polkit-1
+}
diff --git a/app-portage/sisyphus/sisyphus-99999.ebuild b/app-portage/sisyphus/sisyphus-99999.ebuild
deleted file mode 100644
index 46c7c7bf..00000000
--- a/app-portage/sisyphus/sisyphus-99999.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-inherit eutils git-r3
-
-DESCRIPTION="A simple portage wrapper which works like other package managers"
-HOMEPAGE="http://redcorelinux.org"
-
-EGIT_BRANCH=master
-EGIT_REPO_URI="https://gitlab.com/redcore/sisyphus.git"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="app-portage/gentoolkit
- app-portage/portage-utils
- sys-apps/gentoo-functions
- sys-apps/portage"
-
-src_install() {
- # create database and csv folders
- dodir /var/lib/${PN}/{csv,db}
- # install the backend
- dodir /usr/$(get_libdir)/${PN}
- insinto /usr/$(get_libdir)/${PN}
- doins ${S}/backend/libsisyphus.sh
- # install the cli frontend
- dobin frontend/cli/${PN}-cli
- dosym /usr/bin/${PN}-cli /usr/bin/${PN}
- # install the gui frontend
- #
- #
- # work in progress
- # not finished yet
- #
- #
-}