summaryrefslogtreecommitdiff
path: root/app-portage
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-06-12 02:59:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-06-12 02:59:01 +0100
commitfb67845e14cb6b5caf543ac150edc3195df4fd89 (patch)
tree00291e2f27ce55b49b58b512ba3d7adca970a834 /app-portage
parentf3ff4b5355ad0fa8b1f83815c1aaea7c69a9be18 (diff)
app-portage/sisyphus : new package (only CLI frontend for now, replacing epkg)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/sisyphus/sisyphus-99999.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-portage/sisyphus/sisyphus-99999.ebuild b/app-portage/sisyphus/sisyphus-99999.ebuild
new file mode 100644
index 00000000..46c7c7bf
--- /dev/null
+++ b/app-portage/sisyphus/sisyphus-99999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils git-r3
+
+DESCRIPTION="A simple portage wrapper which works like other package managers"
+HOMEPAGE="http://redcorelinux.org"
+
+EGIT_BRANCH=master
+EGIT_REPO_URI="https://gitlab.com/redcore/sisyphus.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-portage/gentoolkit
+ app-portage/portage-utils
+ sys-apps/gentoo-functions
+ sys-apps/portage"
+
+src_install() {
+ # create database and csv folders
+ dodir /var/lib/${PN}/{csv,db}
+ # install the backend
+ dodir /usr/$(get_libdir)/${PN}
+ insinto /usr/$(get_libdir)/${PN}
+ doins ${S}/backend/libsisyphus.sh
+ # install the cli frontend
+ dobin frontend/cli/${PN}-cli
+ dosym /usr/bin/${PN}-cli /usr/bin/${PN}
+ # install the gui frontend
+ #
+ #
+ # work in progress
+ # not finished yet
+ #
+ #
+}