summaryrefslogtreecommitdiff
path: root/app-text/poppler/poppler-0.32.0.ebuild
diff options
context:
space:
mode:
authorBlackNoxis <steven.darklight@gmail.com>2015-04-21 22:24:48 +0300
committerBlackNoxis <steven.darklight@gmail.com>2015-04-21 22:24:48 +0300
commitb70efef53cc9de063fe3974dd56d672a92e57a9f (patch)
treeafd40e71be8de842afd562eda001b21abc9019c3 /app-text/poppler/poppler-0.32.0.ebuild
parent0fc61a35b43840a592037ab8bf88af6142527e3c (diff)
parent9a2973bcf4baaf0fa7848cd93e45ea1b7cd1a110 (diff)
Merge branch 'master' of github.com:Rogentos/kogaion-desktop
Diffstat (limited to 'app-text/poppler/poppler-0.32.0.ebuild')
-rw-r--r--app-text/poppler/poppler-0.32.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-text/poppler/poppler-0.32.0.ebuild b/app-text/poppler/poppler-0.32.0.ebuild
new file mode 100644
index 00000000..c0024291
--- /dev/null
+++ b/app-text/poppler/poppler-0.32.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base (meta package)"
+HOMEPAGE="http://poppler.freedesktop.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0/51"
+IUSE="cairo cjk curl cxx debug doc +introspection +jpeg jpeg2k +lcms png qt4 qt5 tiff +utils"
+
+COMMON_DEPEND="
+ ~app-text/poppler-base-${PV}[cxx=]
+ ~app-text/poppler-base-${PV}[curl=]
+ ~app-text/poppler-base-${PV}[debug=]
+ ~app-text/poppler-base-${PV}[jpeg=]
+ ~app-text/poppler-base-${PV}[jpeg2k=]
+ ~app-text/poppler-base-${PV}[lcms=]
+ ~app-text/poppler-base-${PV}[png=]
+ ~app-text/poppler-base-${PV}[tiff=]
+ ~app-text/poppler-base-${PV}[utils=]
+ "
+
+DEPEND="${COMMON_DEPEND} virtual/pkgconfig"
+
+PDEPEND="cairo? (
+ ~app-text/poppler-glib-${PV}[cairo,introspection=,doc=]
+ )
+ qt4? ( ~app-text/poppler-qt4-${PV} )
+ "
+# add qt5 support when needed
+
+RDEPEND="${COMMON_DEPEND} cjk? ( >=app-text/poppler-data-0.4.4 )"