summaryrefslogtreecommitdiff
path: root/app-text/simplenote/simplenote-2.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-15 10:11:29 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-15 10:11:29 +0000
commitaf9b135f3117af988823e05a03b31d2a745d11d3 (patch)
treeaec92d583144c63092e9043cc2623ba54b821f2a /app-text/simplenote/simplenote-2.6.0.ebuild
parentbf9847557f3c9ff074a14f5c12bdfd29716ecf6b (diff)
app-text/simplenote : version bump
Diffstat (limited to 'app-text/simplenote/simplenote-2.6.0.ebuild')
-rw-r--r--app-text/simplenote/simplenote-2.6.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-text/simplenote/simplenote-2.6.0.ebuild b/app-text/simplenote/simplenote-2.6.0.ebuild
new file mode 100644
index 00000000..2c9ed96b
--- /dev/null
+++ b/app-text/simplenote/simplenote-2.6.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils unpacker
+
+DESCRIPTION="The simplest way to keep notes"
+HOMEPAGE="https://github.com/Automattic/simplenote-electron"
+SRC_URI="https://github.com/Automattic/simplenote-electron/releases/download/v${PV}/Simplenote-linux-${PV}-amd64.deb"
+
+LICENSE="GPL2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-libs/nss
+ media-libs/alsa-lib
+ x11-libs/gtk+:2
+ x11-libs/libXtst
+ x11-libs/libnotify"
+RDEPEND="${DEPEND}"
+
+RESTRICT="mirror strip"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack_deb ${A}
+}
+
+src_install() {
+ rm -rf ${S}/usr/share/doc || die
+ cp -R ${S}/* "${D}" || die
+ fperms 4711 /opt/Simplenote/chrome-sandbox || die
+}