summaryrefslogtreecommitdiff
path: root/dev-python/animation/animation-0.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-07-10 21:54:34 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-07-10 21:54:34 +0100
commit33bc4dc2f69a408839e44e1c8ca5feb757c1844a (patch)
treeaad2ce1cdcb77e5970c83d640793388f1a8e1812 /dev-python/animation/animation-0.0.3.ebuild
parent21125a0f6979c4647e4a5d5c308d94e42c279f80 (diff)
dev-python/animation : new package
Diffstat (limited to 'dev-python/animation/animation-0.0.3.ebuild')
-rw-r--r--dev-python/animation/animation-0.0.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/animation/animation-0.0.3.ebuild b/dev-python/animation/animation-0.0.3.ebuild
new file mode 100644
index 00000000..dfcfa6ea
--- /dev/null
+++ b/dev-python/animation/animation-0.0.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tools for terminal-based wait animations"
+HOMEPAGE="https://github.com/bprinty/animation"
+SRC_URI="https://github.com/bprinty/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${PN}-${PV}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+}