summaryrefslogtreecommitdiff
path: root/dev-python/animation/animation-0.0.5-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-27 21:32:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-27 21:32:32 +0100
commit871cc534428ad2b34c2bf3506fc8f89c7046401f (patch)
tree3062fc39bd886bebf28eb63d76187db4dd1ab627 /dev-python/animation/animation-0.0.5-r4.ebuild
parent4952ba6f326b0910564c414b0b8192c0aded26e7 (diff)
dev-python/animation : add python3.11 compat
Diffstat (limited to 'dev-python/animation/animation-0.0.5-r4.ebuild')
-rw-r--r--dev-python/animation/animation-0.0.5-r4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/animation/animation-0.0.5-r4.ebuild b/dev-python/animation/animation-0.0.5-r4.ebuild
new file mode 100644
index 00000000..9e9e38e2
--- /dev/null
+++ b/dev-python/animation/animation-0.0.5-r4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tools for terminal-based wait animations"
+HOMEPAGE="https://github.com/bprinty/animation"
+SRC_URI="https://github.com/bprinty/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL"
+SLOT="0"
+KEYWORDS="amd64 arm64"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${PN}-${PV}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+}